They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
avasili
Score: 12
votes: 14
Format: Article

 How to get Sound Over HDMI With ATI


HDMI Audio is disabled by default on kernel 3.0+ due to a black screen on some monitors.


To get audio working again go to:

etc/default/grub

Open grub as administrator with a text editor.

Then change the line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"

Type on the terminal:

sudo update-grub

Reboot and your HDMI sound will work again.


Tags: HDMI, ATI, SOUND
Created: 2 years ago.
Last edited: 2 years ago.
Reviewed: 2 years ago.
Read 0 times.

Comments
2 months ago

ppkshondo
Thanks  
5 months ago

yusufbolu
Excellent. Thank you very much.  
6 months ago

Tumble
Thanks for this, worked straight away. shame i didn't find it earlier!  
8 months ago

frikkieh
At last. Got it running thanks to this post.
Thank you.
 
9 months ago

streb0r
Worked great, thank you so much.  
1 year ago

MichaelTunnell
Thank you for this tutorial...this helped for my HP Pavilion dv7 laptop.  
1 year ago

avasili
Thanks for your comments.

@Infinite_Waffle: I'm sorry this didn't work. At the moment I don't have my laptop anymore to test again...

I hope you will find a solution.
 
1 year ago

Davdaw4
Solved the problem on my Acer Aspire One 725 running Mint 14 MATE. Thanks for the great advice.  
1 year ago

Infinite_Waffle
This did not work for me. Running Cinnamon Mint 14 on a thinkpad t520. Did not send through hdmi automatically, and not showing as a source in settings or kmix.  
1 year ago

hackalite
Thank you very much ^^  
1 year ago

avasili
Glad it helped. :-)  
1 year ago

Whatzit
Awesome! I'm actually running Ubuntu 12.10 in a Sony VAIO (which came pre-installed with Vista).

It worked like a charm! Now I can hear audio from my HD TV.

Thanks!
 

Other tutorials from avasili