They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
clem
Score: 174
votes: 221
Format: Article

 Plymouth - How to improve the resolution


Problem

Your boot screen looks like this:

Or like this:

Cause

Your computer is simply using the wrong resolution and the wrong color depth. 

Solution

  1. Launch the Startup Manager from "Menu->Administration->Startup-Manager". 
  2. In the "Boot options" tab, change the resolution to something your monitor can handle (1024x768 is usually enough for the boot screen to look nice).
  3. Change the color depth to "24 bits"
  4. Press the "Close" button.

Upon reboot, your startup splash screen should now look like this:


Tags: boot sequence plymouth loading load startup splash screen resolution ugly bad looking
Created: 4 years ago.
Last edited: 3 years ago.
Read 105033 times.

Comments
3 months ago

liltimmy
This program was the only thing that allowed the splash screen to be rendered in Mint 17 with Nvidia 450GTS and 304 driver.  
4 months ago

bkjaya1952
Thanks  
4 months ago

mmustoe
Being a complete newb, I see why Gurus want every contribution to live up their standards, but I say Thanks, for someone trying to provde help! I've been living by digging deep and other's help, while trying to make the cutover.  
11 months ago

mervg
This is SO outdated.  
11 months ago

Sir_Douglas
How do we improve on 1024 X 768 to fit wide screens of better resolution?  
1 year ago

sserbanro
This tutorial applies to?!?
What Linux version? What DM/WM?
Theming a DM is one thing and using a DIFFERENT OS VERSION, is something else.
You are assuming that all users work un your computer?
Be more specific, please, there are thousand of configurations and machines and each app behaves differently on a different BIOS, CPU, and so on.
Such kind of tutorial is supposed to start with:
Machine:...
OS:...
Last update:...
Specific software:...
For instance, I have a different version of Mint, with OpenBox+XFCE (Yeah, a melange...), different menus, different items under each menu, lack of color depth settings, refresh rate and resolution.
 
1 year ago

kherring7383
When I installed Mint 14 and then updated my Nvidia card driver the Mint Splash was no longer visible. As a fix, I applied the following script and set the resolution to 1024x768 and the color depth to 24bit.

Ref:http://www.webupd8.org/2010/10/script-to-fix-ubuntu-plymouth-for.html)

cd
wget http://launchpadlibrarian.net/121675171/fixplymouth
chmod +x fixplymouth
./fixplymouth
sudo update-initramfs -u
 
1 year ago

mideal
24 bit colour depth for the small Mint logo is kind of a joke, isn't it?
Gonna try this later with 1680*1050, should look really cute :-)
 
1 year ago

Zymsmith
A search of Apps on new Mint 14/KDE brings:
GRUB2 Bootloader
"Customize the Grub2 Bootloader"

Nice and easy, all settings. This after too many hours wrestling with Grub
in serveral install attempts.
 
1 year ago

mysoomro
I tried to follow the tutorial, but settings in my system were a bit different. In my system, Linuxmint 13 XFCE, it's in the Settings->Session and Startup. And it doesn't give any option for changing the resolution. But I didn't need it because my system already uses the optimal resolution even in Plymouth.  
2 years ago

grimdestripador
Consider changing title to represent content. Somethign like: Fix Boot Splash Linux Mint 12  
2 years ago

grimdestripador
Q: What if on booting from DVD (1st time installation), you got a blank screen?
A: Your monitor on your laptop is in sleep mode. Press the F-key associated with increasing your brightness, this will turn your screen on. Also Ctrl-Alt-F1, then Ctrl-Alt-F7 would also accomplish this.
 
2 years ago

major
What if on booting from DVD (1st time installation), you got a blank screen?  
2 years ago

indrasan
Excellent Tutorial, I searched for startup-manager then I Install the package and everything works  
2 years ago

kazztan0325
@saintdanbert and other Mint 12 users who were disappoined with this tutorial:

I posted a workaround as a comment on a idea "Change startup splash screen" a few days ago.
Please refer it if you are interested in.

 
2 years ago

machanch
I have installed Mint12 on my desktop, I cannot find Menu > Administration >... The System Tools Menu contains (Config Editor, GDebi Package Installer, Power Statistics, System Monitor, System Setting, UXTerm and XTerm).. The GDebi Package Installer when launched does a loading, but does not display anything.

Ok I have had a good look through the various menus and the administrative apps are all associated with the Menu 'Other'.. I would not have thought to look ther for such an important set of application. I think something more descriptive of those application should be used.. Like 'Administration' as mention here in these comments..

Is there a way the rename for e.g. 'Other' to 'Administration'?... I for one cannot see how to do this...
 
2 years ago

reg71
Agree with saintdanbert. Just installed, launched tutorial from startup screen on desktop and the tutorial doesn't apply to this version.  
2 years ago

saintdanbert
I'm running Mint-12. I don't have a Menu-->Administration anything !! (There is no Administration item on the page that appears when I touch the gear-icon, Menu button on the bottom left of the screen.

If a tutorial is specific to a given edition of the distro, then the tutorial might be better if it said so at the top.

Disappointed,
~~~ 0;-Dan
 
2 years ago

lonepainter
Open Menu > Administration > Synaptic Package Manager. Do a search for packagemanager. Install the package, once complete from terminal:

sudo packagemanager


That should give you the options listed above.
 
2 years ago

rustong
How do I find the Startup-Manager in LXDE?  
2 years ago

Gurman
:(
Where is 1280x800, 1366x768, 1920x1080 in Julia?
 
3 years ago

blueXrider
For Katya:

Download "plymouth-theme-mint-logo" and "plymouth-theme-mint-text" using PACKAGE MANAGER

Then apply the tutorial suggestions

nice boot screen afterwards
 
3 years ago

RavS
Did use this once. Thanks!  
3 years ago

RavS
Did use this once. Thanks!  
3 years ago

kazztan0325
@blueXrider:
Sorry, I was silly.
I just thought this tutorial is still relevant to users except Katya.

And you are right.
This tutorial should be updated to latest content based on the present state.

Please forgive me for my stupidity, my friend!
 
3 years ago

blueXrider
I think we should not forget there are not only Katya users but also Julia / Isadora / and other releases users here.

Kazz, Should I have been more specific?

WE NEED AN UPDATED TUTORIAL FOR JULIA AND ISADORIA PLUS KATYA.

I'm sure Mr. Clem is aware that this information is out of date.

Don't want to be a B***h here.
 
3 years ago

kazztan0325
@blueXrider:
I think we should not forget there are not only Katya users but also Julia / Isadora / and other releases users here.
 
3 years ago

blueXrider
Could we get an update on this subject. It's been over a year ago so current information is not relevant here. Thanks  
3 years ago

Kim_Kusanagi
Erm... Linux total n00b converted from Vista over here. I noticed today that I was having the first screen after installing the nvidia drivers two days ago (I usually let the computer do everything without paying attention until it reaches the login screen). So, I decided to run this procedure and it worked almost flawlessly, except that after the boot sequence runs out, but before the login screen appears, an "error" message shows on screen during what seems to be a couple of seconds, so I can't read it clearly, but it also worries me. What could this be and how could I fix this, in case anyone has experienced this? Thank you and see you soon.  
3 years ago

Morttis
truly the Startup-Manager me bailed good tool  
3 years ago

AlexVoiD
Thanks!  
3 years ago

99er
That was quite helpful, thank you very much.  
3 years ago

Kanex_chin
Good Tips  
3 years ago

dreamtrip
A good crisp tutorial. One that would encourage even the newest of newbies to experiment with Linux and highlights its customisability. good job.  
3 years ago

sdim
Fixed.ALT+F2-->Startup manager, do it from there.
Many thanks, Leit.
 
3 years ago

sdim
OK, that works in Gnome, but what do we do in KDE?
Where are the settings there, to fix this?
 
3 years ago

Vijesh
Thanks  
3 years ago

dioal
cool .. i'll try this one  
3 years ago

RuperttWind
I did this , and i accidentally set the resolution to high

now i cant see the boot screen at all
it shoes invalid freequency or resolution that is not supported by the monitor

and i also made the default boot option as windows 7
now i cant get into Linux at all

how can i restore the screen back to its original state .

i run a linux mint 10
 
3 years ago

gregzeng
Hope this works on my portrait 24 inch screen. Win7-32, Ubuntu, Super OS do. Trying the various versions of Mint. I want to choose which op sys, cos they all use the NTFS-3G compressed partition in the extended partition.

The 20 gb root partion, Grub, Win7-32 are the other 3 partitions. The extended contains my mount (256 mb) and data partitions (400+gb).

Australian Capital Territory
 
3 years ago

Tonya
Thank you very much! Looks good!  
3 years ago

LizardGamer
This is great, but this problem has to be fixed!  
3 years ago

tiger2wander
Helpfully tut, thanks!  
3 years ago

rickbee
worked for me too, but took ages to complete process, more than five minutes, which is rather strange. Be patient guys  
3 years ago

lionheart
This worked for me even on LM 10 KDE RC, I choose 1024x768 resolution and 24 bit color depth. I'm using the propietary drivers for my ATI HD3200 graphic chipset  
3 years ago

KirkM
This has always worked for Linux Mint Main Edition (Gnome) but unfortunately does not work for LM 10 KDE RC. Doesn't seem to have any effect at all. Not that it affects the actual function of booting up and shutting down, it's just a bright blue screen is hard on the eyes.

Running the latest "Recommended" Nvidia driver for a Nvidia GT 220.
 
3 years ago

mikefreeman
Any chance of this fix being included by default in the next release? I've had to do twice so far (Isadora and Julia), and it's getting a little old, not to mention it looks bad to those who are trying Mint for the first time. Perhaps something that detects your hardware and adjusts the startup resolution settings when you install the system would work?  
3 years ago

dances1000
Any tips on changing the boot splash animation. Let me know. Pm me.
 
3 years ago

Sol_Badguy
Great!  
3 years ago

Qruqs
This not only solved the color/resolution problem, it also solved the problem I had with the computer not shutting down. Go figure...  
3 years ago

Ehecatl1138
And this is how should be do it! THX!!!  
3 years ago

soloist4ever
Oh looks good!
Thanks :D
 
3 years ago

epopuI
Great, simple instructions  
3 years ago

csmgj
That was easy :)  
3 years ago

MyLinuxMint
Great write-up! Easy to follow!  
3 years ago

hazmint33
nice info. thanks  
3 years ago

grey1960envoy
I am surprised at how different it looks and I thank you for helping me get rid of the text at start (I must have made an error when I was setting up the start up page etc.)!  
3 years ago

dwpbike
excuse my ignorance. i was in a rush to address resolution between power cycling laptop when video disappeared. it does look better when booting to blank screen. and i now know to head to forum. oh, and this is dell inspiron 1100, a32 bios, 1gb ram.  
3 years ago

dwpbike
there is no "Menu->Administration" on linux mint 9 lxde  
3 years ago

sythe
This will be fixed by Mint 10, right?
 
3 years ago

rahulsinha080
its really nice  
3 years ago

ktymint
Thank you very much.
Great. It works perfect.
 
3 years ago

james1345
wow - never realised it wasn't supposed to look like that :P  
4 years ago

xiao66lv
Great  
4 years ago

Eugenian
I'm running Mint 9 from a USB flash drive with persistence. When I try to launch Startup Manager, it opens for a fraction of a second and then quits. (I assume that will change after I do a hard drive install.)
 
4 years ago

justin
@devon8 this is not a help forum, see the comment below from @clem. You should be posting your queries in the relevant part of the Linux Mint forums or finding support in the IRC channel.  
4 years ago

devon8
I have a problem trying the Live CD as all I get is the dot screen then it all goes blank. There doesn't seem a way to adjust screen resolution from start up.
Running Helena 8 on Dell Inspiron 510m currently ok using 640*480 with Compiz. Not sure how to adjust up to 800*600 or even if it will do it.
Any thoughts appreciated.
 
4 years ago

migero
hi there just installed mint 9 gnome cd version on my primery resolution
1280x800 60hz is all mesed upseeing only upper left side of screen all blinking make trough installation and changed to 800x600 is ok now
 
4 years ago

clem
@seanearlyaug:

This isn't the place to get support.
We do provide CD images.
We do not sell discs. To get a refund, please contact the company who sold this disc to you.
You should check the integrity of the disc before asking for a refund.
 
4 years ago

seanearlyaug
I bought a Mint 9 disk. I did this to get a clean and dependable install.
I got this problem, just 5 dots showing.
I can not access the OS.
I can not change the resolution.
The disk and the OS seems worthless.
Should and How should I ask for my money back, and when will a
CD not DVD be available? My other machine does not boot off of CDs, neither machine boots off of USBs.
Is there a way to go from DVD to whole system with out booting?
 
4 years ago

xavierp94
Excellent! Thanks!  
4 years ago

itbcn8
thanks! now i need to figure out how to take the "safe mode" linux mint option off of my grub boot menu and i'm set! ;)  
4 years ago

genoskill
thank you very much, man.  
4 years ago

Timoteii
Excellent Tutorial, easy to read, easy to understand & easy to follow

Great Work!
 
4 years ago

arthrotec
Hi:
This tutorial seems to have worked well. However, is there any way to adjust the refresh rate of the grub screen. I'd like it to fill the screen, but it is a green box with black borders. To be clear, I'm speaking of the screen where you choose operating systems (I'm dual booting).
Thanks
 
4 years ago

ivanblago
Thanks,
works for me!!!

Cheerss.....
 
4 years ago

gdgiowa
Thanks Clem!

Just installed Isadora 9 64 last night.

Made this adjustment and now it works. (NVIDIA GT210 card)
 
4 years ago

jkw
I did some changes in the startup manager, with my nvidia card, which resulted in a re-install. So beware of what you're doing if you're going to attempt it.  
4 years ago

wolfprint
.... and if this doesn't help, you might find something of use at http://news.softpedia.com/news/How-to-Fix-the-Big-and-Ugly-Plymouth-Logo-in-Ubuntu-10-04-140810.shtml which was from http://idyllictux.wordpress.com/

It helped me with the same problem
 
4 years ago

sadi
I use Linux Mint 9 in Persistent Live mode, and my splash screen problem has solved been solved by adding the boot parameter "i915.modeset=1" as recommended by Ubuntu folks :-)  
4 years ago

remoulder
Note using Startup Manager adds deprecated options to your grub config and may overwrite any existing kernel options you have already added, so here is an alternative method:

Open a Run box with Alt+F2, enter gksu gedit /etc/default/grub and click Run.

In the editor find the line #GRUB_GFXMODE=640x480 and delete the leading #. If you want a higher resolution you can change the value after the =, but I recommend you stick to one of the common resolutions 800x600, 1024x768 or 1280x1024. You can change the colour depth by added it to the end of the value as in x32 for 32 bit colour. Ensure your monitor is able to handle the resolution you set or you will probably get a black screen.

Now add a new line after that one with the value GRUB_GFXPAYLOAD_LINUX= setting the value after the = to the same as you used before.

Once you've made the changes save the file and exit.

Now open a terminal using Ctrl+Alt+T (in Gnome) and enter

sudo update-grub

enter your login password when asked. If all goes well it should generate a new grub.cfg file and end with the line done.

That's it, reboot and check if it worked.
 
4 years ago

desQEDo
Works perfectly on a Dell Mini 9. Only the Mini 9 resolution setting 1024x600 is not available. Nevertheless 640x480 @ 24 bit color depth looks fine. I have Show boot splash and Show text during boot, under Misc. unchecked.
Except for WLAN driver everything worked "out of the box" but even that driver was offered and installation worked perfectly loaded by wired LAN.
 
4 years ago

Schiphol
Uhm. Not working for me. I have the dot line and an uglyish font reading "Linux Mint 9". I actually like the text, but I know it's not behaving as intended :)  
4 years ago

pazuzuthewise
With the fix provided by this tutorial, it works perfectly on a PC with Radeon HD 3470 with the KMS driver.
Before fixing, from the live cd it was OK, but after install and reboot, the bootsplash wasn't visible and, an even more serious problem, the computer didn't halt on shutdown (same bug as in Ubuntu Lucid)
The only problems are those that remain with the KMS driver per se, the horizontal lines visible on dark background, and the increase in temperature.
I haven't tried the fglrx driver yet in Isadora, but in Lucid, the 2d acceleration was missing altogether (was like trying to run WinXP on a 486)
 
4 years ago

spocky184
Works perfect after Nvidia Driver installation on a Zotac MAG Mini HD-N01. Set the resolution to 1280x1024 and 24bit.
Thank you for that hint !
 
4 years ago

tux-sven
On my Asus Aspire One D250 I changed from 8 bit color deep to 24. After that I got serious problems starting the computer. I changed it to 16 bit and it starts. My resolution is set to 800x600. It only shows the Linux Mint logo for 1 or 2 seconds and then it's a black screen until the green login screen appears.
I have marked "Show boot splash" but it's still black until the green login appears. ??
"(process:183 GLib-WARNING getpwuit_r():faliled due to unknown user id (0)" was sometimes possible to see when I had trouble with starting (24 bit).
 
4 years ago

linuxmint
Nice tutorial. This will be useful to all users and like anyoneelse said, we should have mint set the settings itself.  
4 years ago

npap
Yes! That did it.
The resolution was originally preset at 800x600 at 8 bits. After resetting it to 1024x768 24-bits, the splash screen looks good and there are fewer crash instances.
npap
 
4 years ago

topjolly
Will there be widescreen resolutions included in the final release?  
4 years ago

jatwood
Thanks for the info on the better resolution. I figured that it would be corrected on final releases since it's listed as a known problem on the RC, but nice to have a way to correct now.  
4 years ago

anyoneelse
I think it would be better if you make Mint set this itself.  
4 years ago

kneekoo
Thanks for the tip. It's just that I get that image on my live CD boot with my Gigabyte Radeon HD5770. On ASUS EAH4350 Silent it looks just like in your second picture. I can't say I enjoy adding vga=xyz to the boot sequence simply to improve the splash screen image from a live CD.

I hope there's a better way to detect the graphics cards and set them up properly because it's an ugly first impression.
 

Other tutorials from clem