They offer different flash templates with latest features.
Login

Forgot password
Register

 MFC-7420

Brand: Brother (Printer/Scanner/Multifunction)
Back

Release: Sarah
Status: Works perfectly
 
Owner:
lostpoetjj

What works:

Works as printer and scanner. I have not tried using it to fax documents from the computer.

What doesn't work:

Linux Mint does not come with drivers for this printer. You have to download them from Brother's site. Brother provides Debian packages that install the drivers and (supposedly) set up a printer queue in CUPS. The drivers install okay but as of Linux Mint 18, the printer queue setup is not done correctly. This caused at least three problems:
1. When I tried to use the printer from an application (eg, print a PDF using xviewer) the dialog box showed 'Waiting for printer to become available'.
2. If I tried to print from the command line, eg 'lp -PMFC7420 file.txt', there would be a notification that the file was being printed, but nothing would print.
3. If I rebooted or restarted CUPS ('sudo service cups restart') with the printer attached and powered on, CUPS would configure a new entry for the printer using an incorrect driver.

To fix this I had to manually delete the printer queue added by Brother's script and create my own. See instructions below.

What was done to make it work:

(Linux Mint 18.1 Serena, Cinnamon edition, 64-bit)

The Brother printer drivers are 32-bit so if you have a 64-bit system, make sure the 32-bit libraries are installed, by installing the 'ia32-libs' package (eg, use Menu -> Administration -> Synaptic Package Manager).

I saved the drivers in ~/lib/software. Otherwise:
Get the printer and scanner drivers for the MFC-7420 from Brother's site
http://support.brother.com
Follow the prompts to find the latest correct Linux 'deb' (Debian) packages. Brother provide a script to do this and install the packages but I recommend you download the packages manually and install them as explained below.

PRINTER

* Install the lpr driver and cupswrapper driver Debian packages from Brother's site. They are 32-bit packages and my system is 64-bit. Gdebi would not install these drivers, complaining of wrong architecture, but they do work. I downloaded them and installed them with dkpg instead:

cd ~/lib/software (or wherever you put them)
sudo dpkg -i --force-all brmfc...
sudo dpkg -i --force-all cupswr...

* (If your system is 64-bit) As advised in Brother's instructions, copy the libraries to the correct location for the 64-bit system:

umask 022 # to avoid permission problems
sudo mkdir /usr/lib64/cups /usr/lib64/cups/filter /usr/lib32
sudo cp /usr/lib/cups/filter/brlpdwrapper* /usr/lib64/cups/filter
sudo cp /usr/lib/libbr* /usr/lib32/
sudo cp -pr /usr/lib64/lib* /usr/lib64/sane /usr/lib

* In System Settings -> Printers
- Remove the MFC7420 entry added by Brother script
(for me, with Linux Mint 18, this entry wouldn't work:
print dialog boxes always said
'Waiting for printer to become available')
- Add new entry for the printer. In 'Choose Driver', select
'Select Printer from Database', then Brother,
then 'MFC7420 for CUPS'
- Configure the printer as you prefer.
- Test print.

SCANNER

* Make sure the package 'sane-utils' is installed (eg, use Menu -> Administration -> Synaptic Package Manager).

* As advised in Brother's instructions, add the following lines to

/lib/udev/rules.d/40-libsane-rules

Put them at the end of the list of vendors, just before the line
that says "# The following rule will disable"

# Brother scanners
ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes"

* Download and install the scanner driver (brscan2) and scan-key-tool packages from Brother's site.

* For 64-bit system, copy the libraries:

cd /usr/lib64
sudo cp -pr lib* sane /usr/lib

(-p preserves permissions, -r recurses into subfolders)

* Reboot (to restart daemons)

* Run Simple Scan from the Graphics menu to test the scanner.

If anything doesn't work, try rebooting.

Additional notes:

The procedure should work for any of the Brother models that use the brscan2 driver. This is Brother's list at 13 May 2012:

brscan2 models
DCP-110C DCP-115C DCP-117C DCP-120C DCP-130C DCP-135C DCP-150C
DCP-153C DCP-155C DCP-310CN DCP-315CN DCP-330C DCP-340CW DCP-350C
DCP-353C DCP-357C DCP-540CN DCP-560CN DCP-7010 DCP-7020 DCP-7025
DCP-750CW DCP-770CW DCP-8060 DCP-8065DN MFC-210C MFC-215C MFC-230C
MFC-235C MFC-240C MFC-260C MFC-3240C MFC-3340CN MFC-3360C MFC-410CN
MFC-420CN MFC-425CN MFC-440CN MFC-465CN MFC-5440CN MFC-5460CN MFC-5840CN
MFC-5860CN MFC-620CN MFC-640CW MFC-660CN MFC-665CW MFC-680CN MFC-685CW
MFC-7220 MFC-7225N MFC-7420 MFC-7820N MFC-820CW MFC-845CW MFC-8460N
MFC-8660DN MFC-8670DN MFC-885CW MFC-8860DN MFC-8870DW MFC-9420CN


Created: 5 years ago.
Last edited: 1 year ago.
Read 0 times.

Other devices from lostpoetjj