525M

telcnas
  6 years ago
  Nvidia (Graphics/Video/TV card)
  Mint (older version)
  Works perfectly
What works:

Bumblebee 3.0.1-3~preciseppa2
Bumblebee-UI or Bumblebee-Indicator
Latest nvidia-current 304.64-0ubuntu1~precise~xup1