4.1 (MB403LL/A)

  7 years ago
  Apple (MacBook)
  Works fine with some minor problems
What works:

Keyboard & media keys
Touchpad (with issues... see below)
Sound (problems in earlier versions of Mint, but not now)
USB ports
"Laptop stuff" including lid hardware, power button, battery information, etc.

What doesn't work:

Touchpad has issues
iSight camera

What was done to make it work:

Installed b43 driver [ http://wireless.kernel.org/en/users/Drivers/b43#Other_distributions_not_mentioned_above ] from source, however, installing `firmware-b43-installer` from the package manager should work too *if* you have access to the internet via an Ethernet connection. I didn't so...

On computer with an internet connection, download the following two files (e.g. onto a flash drive or other method):

Then, on the MacBook with the Broadcom Corporation BCM4321 wireless chip, you'll run:
make && sudo make install
in the b43-fwcutter (extracted/unzipped) directory THEN (afterwards) run:
sudo b43-fwcutter -w "/lib/firmware" broadcom-wl-5.100.138/linux/wl_apsta.o
in the broadcom_wl directory.

Restarting the computer (or just the wireless service really) will allow the wireless to work properly.

I had issues with the touchpad expecting MUCH more pressure on the touchpad than necessary.
To remedy this *IN THE PAST* Linux Mint distros, I simply added a file at '/usr/share/X11/xorg.conf.d/10-synaptics.conf' with the follwing:
# See: http://manpages.ubuntu.com/manpages/lucid/man4/synaptics.4.html
# For current settings: `xinput list-props bcm5974`
Section "InputClass"
Identifier "touchpad catchall"
MatchIsTouchpad "on"
MatchDevicePath "/dev/input/event*"
Driver "synaptics"
Option "FingerHigh" "10"
Option "PalmDetect" "on"
Option "LockedDrags" "on"
Option "JumpyCursorThreshold" "90"

However, in the newest updates, that file no longer was being picked up at startup for some reason. I edited '/usr/share/X11/xorg.conf.d/50-synaptics.conf' even though the file clearly says not to...
Just edit the section that starts with 'Section "InputClass"' to something like this:
Section "InputClass"
Identifier "touchpad catchall"
Driver "synaptics"
MatchIsTouchpad "on"
Option "FingerLow" "2"
Option "FingerHigh" "4"
Option "PalmDetect" "on"
Option "LockedDrags" "on"
Option "JumpyCursorThreshold" "90"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
# MatchDevicePath "/dev/input/event*"

Those settings aren't perfect, but work __much__ better.

I honestly haven't tried to fix in the latest Debian, but in the past installing & running isight-firmware-tools on the firmware from OS X did the trick.