R9 270X

Deezel
  5 years ago
  ATI Radeon (GPU)
  Mint (older version)
  Works fine with some minor problems
What works:

With latest binary drivers from amd.com
user@system:~$ glxinfo | grep OpenGL
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon R9 200 Series
OpenGL core profile version string: 4.3.13084 Core Profile Context 14.301.1001
OpenGL core profile shading language version string: 4.40
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.4.13084 Compatibility Profile Context 14.301.1001
OpenGL shading language version string: 4.40

What doesn't work:

At the moment it does not work well with any of the drivers in Driver Manager

What was done to make it work:

Download latest drivers from amd.com
user@system:~/Downloads$ unzip amd-catalyst-14-9-linux-x86-x86-64.zip
user@system:~/Downloads$ cd fglrx-14.301.1001/
user@system:~/Downloads/fglrx-14.301.1001$ sudo ./amd-driver-installer-14.301.1001-x86.x86_64.run
opens an install app that guides through the installation.