ThinkPad T42

mintconsumer
  4 years ago
  IBM (Laptop or Netbook)
  Mint (older version)
  Works partially
What works:

Installation, internet, all programs, standby mode.

What doesn't work:

Hibernation is broken. Laptop won't resume properly. The error message is along the lines of "/dev/sda5 was not unmounted cleanly, check forced." Then it sits there indefinitely until Ctrl-Alt-Delete is pressed. On reboot it sometimes re-scans all partitions and does a normal boot to GUI.

What was done to make it work:

Swap partition is 2.5 GB vs. 1-2 GB RAM and the hibernation phase seemingly completes normally, laptop shuts down fully on its own. Tried updating everything - no improvement. Tried IBM stickered hard drives too. So it doesn't seem like a hardware problem. WinXP and Win2k work perfectly.

Uninstalled Plymouth; textual LM9 logo with running dots looks much better :-) Still won't resume from hibernation.

Tried playing with BIOS settings. Tried BIOS 3.21 and 3.23. 3.21 has the "old-style" USB enumeration for Win9x, 3.23 has the "modern" enumeration.

Additional notes:

This particular T42 is type 2379-DXU, Pentium M "Dothan",
Radeon 9600 AGP 64 MB 128-bit, stock 1400x1050 15" LCD.