X93SV-YZ145V

leolivier
  3 years ago
  Asus (Core(TM) i7-2670QM CPU @2.20GHz)
  Mint (older version)
  Works fine with some minor problems
What works:

Almost everything

What doesn't work:

- no HDMI output (was in 17, not tested in 18)
- problems with Bluetooth (external usb key ASUS BCM20702, worked with 17.3),

- had a serious problem when migrating from 17.3 to 18 with my nvidia driver that refused to load and the X-server refused to start. see below how I fixed it. Now it works fine...

What was done to make it work:

To solve the nvidia driver issue, I had to
* switch to a tty (Ctrl-Alt-F2 for instance),
* login,
* edit the /etc/X11/xorg.conf file to set vesa instead of nvidia
* run startx (yeah, X11 AND cinnamon finally started in a weird mode...)
* reinstall the driver (sudo apt-get install --reinstall nvidia-361)
* run driver-manager
* back and forth chose nvidia 361 and nvidia 304
* restart the whole process several time and finally, the nvidia 361 accepted to start

Solved ASUS BCM20702 bluetooth issue by installing manually Blueberry then reboot.
If still no icon in the tray but you can run blueberry manually (and it works), and if
dmesg|grep -i bluetooth
shows lines like:
[ 4.628966] bluetooth hci0: Direct firmware load for brcm/BCM20702A1-0b05-17cb.hcd failed with error -2
[ 4.628980] Bluetooth: hci0: BCM: Patch brcm/BCM20702A1-0b05-17cb.hcd not found

you can try this: http://plugable.com/2014/06/23/plugable-usb-bluetooth-adapter-solving-hfphsp-profile-issues-on-linux, it worked for me.