HL-1210w

DarrenG
  6 years ago
  Brother (Printer)
  Mint (older version)
  Works fine with some minor problems
What works:

I have a Brother HL-1210w mono laser printer.

Linux mint 17.2 identified it and installed it under a label HL-1210W-series describing it as "Brother HL-1230 Foomatic/hl1250 (recommended)"

What doesn't work:

Using the recommended driver Brother HL-1230 Foomatic/hl1250 resulted in very poor print quality, with some lines incomprehensible and strange blotches under descending letters like y p g etc

What was done to make it work:

I downloaded the correct drivers from the Brother website

30/10/2014 (3.0.1-1)

LPR printer driver (deb package)
http://support.brother.com/g/b/downloadend.aspx?c=au&lang=en&prod=hl1210w_eu_as&os=128&dlid=dlf101547_000&flang=4&type3=559

CUPSwrapper printer driver (deb package)
http://support.brother.com/g/b/downloadend.aspx?c=au&lang=en&prod=hl1210w_eu_as&os=128&dlid=dlf101546_000&flang=4&type3=561

Additional notes:

The Brother website included instructions for installing the drivers from CLI but I encountered errors following them. Instead I right-clicked on the packages and selected "Open With GDebi Package Installer" which worked fine.