Apple iMac5,1 MA590LL

mintconsumer
  8 months ago
  Apple (iMac5,1)
  Mint (older version)
  Doesn't work as expected
What works:

Live 17.3 32-bit DVD boots up and goes online through Ethernet. It is possible to adjust all exposed preferences in the control panel. Sound and video work fine.

What doesn't work:

Broadcom wi-fi doesn't show up in Network Utility even after installing non-free drivers using the Driver Utility. Tried installing different updates and non-free drivers through Synaptic to no avail.

Not possible to install to internal or external hard drive because both Gparted and Ubiquity crash with no message when partitioning a hard disk. So I'm guessing it's a problem with parted.

exFAT interfaces are missing on Live DVD.

Can't print to hp LaserJet p1505 eventhough the exact drivers are included. The print queue says "completed" but the printer never starts nor blinks. The included troubleshooter reported "no obvious solutions".

What was done to make it work:

Installed exfat-fuse and exfat-utils through Synaptic and was able to browse the partition.

For printing tried updating CUPS-related packages to no avail.

Additional notes:

iMac5,1 has Intel 945pm chipset, C2D T7200, SATA HDD, ATI Radeon x1600 PCIe graphics.
everymac.com/systems/apple/imac/specs/imac-core-2-duo-2.0-17-inch-specs.html