9 years ago
  Turbowin (Keyboard)
  Mint (older version)
  Works fine with some minor problems
What works:

Back & Forward
Media, Mute, Prev, Next, Play, Pause, Stop
Volume up and Down

What doesn't work:

Web Home did not work at first. It was disabled in Preferences - Keyboard Shortcuts (Desktop section).
Enabling it here caused it to produce an error as it was looking for the application epiphany.
Since I use Firefox I needed to get it to run Firefox.

What was done to make it work:

I got help on the forum
TheDynamicHamza21 suggested that :-
Go to Menu > Applications > Preferences > Keyboard Shortcuts.
Click the Add button to create a custom shortcut.
Enter firefox to both the Name and Command boxes and click the Apply button.
Click on Disabled at the firefox row in the Keyboard Shortcuts window (Disabled is then changed to New shortcut...).
Press a new key combination, e.g. Ctrl+Alt+X (New shortcut... is then changed to Ctrl+Alt+X).
Click the Close button.

I set up a new shortcut for myself, called it firefox and linked it to the XF86homepage button.

The Keyboard now works perfectly!