They offer different flash templates with latest features.

Forgot password


Brand: Linksys (WIFI card/adapter/dongle)

Release: Isadora
Status: Works perfectly

What works:

Connects to the internet via Linksys Wireless router, it finds Qwest Wireless router, and a few others models. Sometimes it will fail to connect, but after a few tries it will eventually connect.

~~~UPDATE 06-11-2010~~~
With the Linux Driver (Ralink rt2870sta) both the 2GHz & 5GHz. It still doesn't find all the access points that a Linux compatible Generic Wireless Card/USB does.

What was done to make it work:

Linux Mint 8 & 9 detects the wireless USB adapter right out of the box but will not work right out of the box.

~~~UPDATE 07-07-2010~~~
Works with Kernel 2.6.34 and up without installing any drivers. (Not too sure about Kernel 2.6.33)

~~~UPDATE 06-11-2010~~~
The Linksys WUSB600N works perfect under Linux Mint 8 & 9 with the Linux Driver.

build-essential ; linux-headers packages

**The Linksys WUSB600N has the Ralink rt2870 chipset (I found this out via., Google).

**Go to the [url=]download section[/url] and download and download the proper driver, in this case it will be "RT2870USB(RT2870/RT2770)."

**(Using the terminal, without Quotation Marks)
**Now you need to install build-essential and linux-headers packages (if you don't have them already):

"sudo aptitude install linux-headers-`uname -r` build-essential"

**Now, in your home folder untar the Ralink package:

"tar -xvjf RT2870_LinuxSTA_V2.3.0.0.tar.bz2"

**Edit the RT2870_LinuxSTA_V2.3.0.0/os/linux/ file to allow network-manager to manage the card. After you have extracted the files, search through the folder OS > linux > and either double click on or right click and open the terminal from that location and input:



# Support Wpa_Supplicant

# Support Native WpaSupplicant for Network Manager

**and change the n's to y's like so:

# Support Wpa_Supplicant

# Support Native WpaSupplicant for Network Manager

**Now enter the RT2870_LinuxSTA_V2.3.0.0 directory, compile and install the driver as root:


**enter your password to load as root.


"make && make install"

**Now, while still root modprobe the driver module:

"modprobe rt2870sta"


"lsmod | grep rt2870sta"

**It should output something like "rt2870sta XXXXXX 0".


"echo rt2870sta >> /etc/modules"




**And that should do it. Worked like a charm for me. The credit for this info is due Fass from Ubuntu Forums which was originally a guide for the Ralink rt2760 PCI Linksys Card WMP110.


Under Ndiswrapper the 5GHz bandwidth doesn't work (I recommend the Linux Driver over the Windows Driver).

Place the Driver CD in the CD/DVD ROM or download from:
( )

Make sure you use/download the correct version. Be Sure that you get the Windows XP 32 bit driver. I am not sure if the 64-bit driver works or not.

Click on Menu > Administration > Windows Wireless Drivers. Or go to the Control Center > System > Windows Wireless Drivers. Direct the ndiswrapper to where the driver .inf is located. And install.

Nest open the Terminal (Menu > Terminal)

'sudo gedit /etc/NetworkManager/nm-system-settings.conf'

enter password and change [ifupdown] Managed from false to true.





Save and your done. You may need to reboot the computer, but it should work after that.

Additional notes:

For some reason this model worked right out of the box one time, it was when I was loaded into the LiveCD, but after that I needed to use the ndiswrapper. I could never figure out why that was.

It works without any problems, it just does not work with its full capabilities.

Created: 7 years ago.
Last edited: 7 years ago.
Read 909 times.

Other devices from JMMR