iBall Rockey

kephalian
  10 years ago
  iBall (Headphones)
  Mint (older version)
  Works perfectly
What works:

Headphone Over the ear type, woks seamlessly in Linux 10.4 Mint Julia