LaserJet 3030 (multifunction)

konasteph
  9 years ago
  HP (Hewlett-Packard) (Printer)
  LMDE
  Works perfectly
What works:

typical: This Printer works in Windows, also with Katya (good girl) even in LMDE the pre 3.0.0.1 kernel. But as soon as Pack 3 was applied to update to 3.0.0.1 the printer became invisible to the printmanager.

Sitting right beside it, the Epson Workforce, also connected through USB, was immediately detected, had no problem installing whatsoever.

whats especially confounding was that $ lsusb showed all usb devices, INCLUDING the hp 3030, the dmesg catalog listed it, so, the system saw the printer, only the printmanager did NOT, hence, I could not install it.

What fixed it? install package hplip and hplip-cups!

(you know, go into Software manager type 'hplip' into the search field) and there they are.

I wish there had been a pointer somewhere in the literature, it would have saved me a lot of time.

What doesn't work:

Again, the printer works BETTER in Linux than in Windows, because the driver maintenance with HP (at least for wINDOWS) has become shoddy.
the latest windows driver does not support the fax function and the scanner (CAN YOU IMAGINE THAT)
In LMDE, as well as in Katya, these are FULLY supported it works AOK

What was done to make it work:

Repeat this again: The Software manager found hplip and hplip-cups
which were actually the first step in obtaining an hp driver.

type in terminal:

dpkg -l hplip

the result then is:


Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
-----------------------------------------------------------------------------
ii hplip 1.7.3-0ubuntu1 HP Linux Printing and Imaging

you see the ii ? that means installed. un means NOT installed.

Additional notes:

After installing the packages (and I am not even sure if the hplip-cups package is actually necessary.)
I was supposed to go and download a driver to be installed in a rather lengthy process.
http://hplipopensource.com/node/306 ..here is the link to all that.

I just had a hunch that the printer might show up already, and it did, and works fine.

My only criticism, if you will, is the fact that all this worked completely automatic and by itself in Katya, so why go and fix it if it isn't broken.

Good Luck