GeForce 9500 GT

Rufus
  10 years ago
  Sparkle (Graphics/Video/TV card)
  Mint (older version)
  Works perfectly
What was done to make it work:

Using nVidia driver version 185, available through Linux Mint hardware drivers