FS-920

bienengasse
  7 years ago
  Kyocera (Printer)
  Mint (older version)
  Works perfectly
What works:

Fine, under "Lisa" just to plugin, no download etc. needed

Additional notes:

Just update the ppd file in the dialog.