ScanMaker 4850

guruwannabe
  7 years ago
  Other (Scanner)
  Mint (older version)
  Doesn't work as expected
What works:

lsusb detected the scanner but scanner is not supported by SANE.

usr@homepc ~ $ lsusb | grep Scanner
Bus 008 Device 002: ID 05da:30d9 Microtek International, Inc. USB2400 Scanner

What doesn't work:

Could not use Scanner in Linux Mint at all

What was done to make it work:

Use Virtualbox on Mint11 hosting WinXp as guest. Well, it was quite unexpected that this should work.
Yes, I still have to rely on WinXp for a couple of things, however, Linux Mint has become my Main OS. Goodbye to dual boot into WinXP.
What I did:
i) lsusb to check that scanner is "detected" in Linux Mint.
--> guess that is why it could "pass it" to Virtualbox.
ii) install Virtualbox 4 - am using the non OSE version from Oracle Virtualbox repo. Not sure if the OSE version works?
iii) install WinXp as guest in Virtualbox :( couldn't kill the beast yet. :) wait til I get a new scanner :).
iv) install the "Microtek ScanWizard 5"
Done! Enjoy scanning in Linux Mint virtualbox.

Additional notes:

Tried Wine w/o success.
Wonder if a "sub-part" of virtualbox could be implemented into Wine??
Anyway old scanners and VCDs would be gone tomorrow. Just make sure to buy hardware that support Linux in the future.

---> update: 20111229@16:27 (GMT+8)
Found this link but have not tried:
https://help.ubuntu.com/community/CheckIfScannerIsClone