List basic system requirements for recent releases.

TeaSwigger
  8 years ago
  36
  Selected

It might be helpful to prospective users to list the basic system requirements for the given release in the announcement page or the download page or the release notes page or the change log page or basically anywhere easily found, so one knows not to waste one's time studying and/or downloading a given release if the hardware won't cut it. At least a minimum RAM the live desktop and installer of a given release can be expected to function dependably with might be advisable.

This information used to be easy to find but for 11 LXDE, for example, it is found if you happen to follow the link to release announcement which is found on the release notes page without an identification that you'll find system requirements there. For recent LMDE releases, I don't see it at all.

Just a suggestion.
Latest comments
jose_manuel 7 years ago

Nice Idea !!!! I Promote this Idea.


sunewbie 8 years ago

It took time for me to search for minimum and recommended requirements. This should make things easy

@kazztan0325:
i agree with you

@remoulder:
I like your idea too
Perhaps a table of minimum and recommended requirements on the download page, plus using a template release announcement?


kazztan0325 8 years ago

I agree with this idea.

I think 'Minimum system requirements' and 'Recommended system requirements' should be shown on the download page or the release notes page.


blueXrider 8 years ago

This would definitively be a good idea.


trollboy 8 years ago

Nice idea. A lot of distributions don't display their minimum or recommended requirements prominently. Doing so would be another easy way to make Mint stand out from the crowd.


remoulder 8 years ago

There does seem to be some inconsistency on this between versions, and as you say the information is not always easily found. Perhaps a table of minimum and recommended requirements on the download page, plus using a template release announcement?