Update pciids for newer hardware

mark-i
  4 months ago
  1
  Under review

When the OS is installed and is a newer PC/Hardware (like from 2017) it has issues detecting properly hardware mostly GPUs and some newer CPUs like Rizen.  To give an example of GPUs this person couldn't install nvidia drivers from driver manager, PPA or straight download and install, this is a sample of his inxi output before updating pci ids with "sudo update-pciids".


Graphics:
Device-1: NVIDIA vendor: ZOTAC driver: N/A bus ID: 01:00.0
chip ID: 10de:1f02
Display: x11 server: X.Org 1.19.6 driver: fbdev,nouveau
unloaded: modesetting,vesa resolution: 1920x1080~77Hz
OpenGL: renderer: llvmpipe (LLVM 7.0 256 bits) v: 3.3 Mesa 18.2.8
compat-v: 3.1 direct render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: ASRock driver: snd_hda_intel
v: kernel bus ID: 00:1f.3 chip ID: 8086:a348
Device-2: NVIDIA vendor: ZOTAC driver: snd_hda_intel v: kernel
bus ID: 01:00.1 chip ID: 10de:10f9
Sound Server: ALSA v: k4.15.0-51-generic

And this is the output of inxi after "sudo update-pciids"

Graphics:
Device-1: NVIDIA TU106 [GeForce RTX 2070] vendor: ZOTAC driver: N/A
bus ID: 01:00.0 chip ID: 10de:1f02
Display: x11 server: X.Org 1.19.6 driver: fbdev,nouveau
unloaded: modesetting,vesa resolution: 1920x1080~77Hz
OpenGL: renderer: llvmpipe (LLVM 7.0 256 bits) v: 3.3 Mesa 18.2.8
compat-v: 3.1 direct render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: ASRock driver: snd_hda_intel
v: kernel bus ID: 00:1f.3 chip ID: 8086:a348
Device-2: NVIDIA TU106 High Definition Audio vendor: ZOTAC
driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f9
Sound Server: ALSA v: k4.15.0-51-generic


I'm not familiar on how easy it would be if the "update-pciids" is done before spinning the iso, or make the installer do the update before initiating the installation.  But this solves about 60-70%  of people having issues with drivers.


 


Best Regards;


MaRk-I

Latest comments
mark-i 4 months ago

The "IDEA" is to update hardware pci ids before spinning a new iso or to do it before the installer begins. I'm not reporting a bug, thanks for the comment they're all welcome useless or not... http://www.linfo.org/bug.html


remoulder 4 months ago

This is a place to post ideas not bug reports, please use the bug tracker or the forums for such posts