IBus Install 100% Working

kybagul
  1 year ago
  -1
  Considered

IBus Install 100% Working


Install First


Press Ctrl+Alt+T open Terminal and type one by and install it.


sudo apt-get install ibus
sudo apt-get install ibus-m17n
sudo apt-get install gir1.2-ibus-1.0
sudo apt-get install ibus-gtk
sudo apt-get install ibus-gtk3
sudo apt-get install ibus m17n-db
ibus-daemon -xdr


After installed IBus restart system.


 


IBus Setting


1. Open IBus and you can see the task bar right bottom corner look like keyboard symbol, right click the symbol Preferences
2. Gerneral Tab - Keyboard shortcuts. click next input method: [...] three dots box.
3. Delete the Control Space. Check Control and press Add and then OK.


Add Input Method


1. Open IBus and you can see the task bar right bottom corner look like keyboard symbol, right click the symbol Preferences
2. Input Method Tab - click Add. clidk bottom vertial three dots type name for example: hindi and select again select itrans(m17n). click Add. and Close
3. Press Ctrl + Space to switch Input Method.

Latest comments
gbgustafson 7 months ago

Linux Mint upgrades through the UPDATE MANAGER from LM17 to LM19 can leave the ibus environment settings blank.
The settings are in /etc/environment.
Broken ibus settings have a recognizable symptom: ctrl-shift-u in editor GEDIT will not produce an underlined U, as is supposed to happen,
according to reference https://wiki.archlinux.org/index.php/IBus#Unicode_input
Editing the following settings into /etc/environment seems to fix the hiccup:
GTK_IM_MODULE=ibus
QT_IM_MODULE=ibus
XMODIFIERS=@im=ibus

The suggestions in https://community.linuxmint.com/user/view/152769
constitute a method to reinstall (instead of install) ibus on LM17-LM19,
in case the ibus install is broken.


umesh 1 year ago

यह विचार की श्रेणी मे नहीं आता है। यह संस्थापन की प्रक्रिया है अतः ट्यूटोरियल्स के अन्तर्गत रखें।


remoulder 1 year ago

This is not an idea