mintmenu click to activate submenu, otherwise searched keywords are frustrating

tpapastylianou
  9 years ago
  8
  Considered

Currently, mintMenu works in such a way that when you hover with your mouse cursor over an application category on the left, it shows the applications within that category automatically on the right, without the need for actually clicking on the category.

While this is a nice feature initially, it becomes very annoying when you start using keyword searches (i.e. the 'Filter' field) to find the stuff you want. The reason is that the filter is usually a small enough word, or part of a word, and a user might instinctively place the cursor as close to the typed filter as possible. However this means that when you subsequently move the cursor in a straight line towards the resulting applications, you'll go past the 'categories' subwindow ... which results in your resulting apps being replaced with the apps in the category you've just accidentally hovered on. So you either have to make a habit of clicking in the Filter field as far away on the right to type in it (which is counterintuitive), so you don't hover over category stuff, or make a ridiculous circle with the mouse cursor to get to your application results, so as to avoid triggering any category showing its apps instead.

I think giving the option to the user to toggle the 'show on hover / show on click' behaviour in the preferences would circumvent this problem.
Latest comments
dagon 7 years ago

Hi!

As this was more of a support case I reject the idea.


new -> rejected


blueXrider 8 years ago

Do you really know what you want?


tpapastylianou 9 years ago

Oh dear. Thanks pluraldave.
And to think I had specifically looked for that, I don't know how I missed it!
Oh well, at least this post might be useful to someone who had the same 'problem'.
Thanks.


Xyie 9 years ago

How about an option to disable the application hover while the cursor is in the filter text field? Since as pluraldave pointed out, we already have the option to have the application categories open by click instead of hover, simply disabling the hover while you're trying to use the filter would probably solve this annoyance.


Keeper_of_Souls 9 years ago

Hmm, this is a very valid point, and it is pretty annoying...


pluraldave 9 years ago

Isn't this exactly what Preferences > Applications > Hover does?