Multiple local soundcards with same simultaneous audio output.

Jeroensky
  9 years ago
  8

Multiple soundcards on LinuxMint.

 

I have a Audigy 2zs soundcard for s/p-dif output (pcm/mpeg/AC3(DolbyDigital)/DTS signals). I also have a onboard soundcard that i use for stereo headphones.

I was looking for a way to let the soundcards play the same audio source at the same time. I found a solution.


If you have more then one soundcard and you want play audio signals (output) on all of them at the same time, then do this:

Step1;

Open package manager and install the packages "pavucontrol" and "paprefs". (without the ")

After that reboot the computer (this is nessesary).

Step2;

Open PulseAudio Preference (paprefs)  Located at -> Settings->PulseAudio Preferences.

Click on the tab "Simultaneous Output", and select the option "Add virtual output device for simultaneous output on all local soundcards". Then click close.

Step3;

Open PulseAudio Volume Control (pavucontrol) Located at -> Multimedia -> PulseAudio Volume Control

Check if the settings are in a way you want it. (what channels on the devices) and that you see the extra device 'Simultaneous output ....' in the Output Devices tab. (if you don't see it, then you need to reboot first!)

Step4;

In the System Tray, Richt click on the icon Volume (Kmix in KDE), and select "Audio setup".

Be sure you move "Simultaneous output ...." to the highest preference position in the audio playback options you want. After that click "Apply", and click "ok".

This can be different in other gui's. But you got the point that "Simultaneous output ...." is the main 1st priority output/play device.

Step5;

In the System Tray, Richt click on the icon Volume (Kmix), and select "Select Master Channel" and choose the channel you want to be controlled by the default volume button(like on a keyboard) or volume icon in system tray.

This can be different in other gui's. But you got the point that you only need to use the analog outputs to control volume.

Keep this in mind: Only analog output needs the volume adjustment. Digital output must stay on 100%.

Done !

And enjoy the same audio playback on all installed soundcards, and really all soundcards that are locally installed  like asa, pci, pci-express, usb, onboard and so on. Of course with Linux support.  ;-)

Comments
MagicMint 7 years ago

This might be a peculiar problem, but it’s well stated, and the fix is nicely described.


jahid_0903014 8 years ago

goood


Jeroensky 9 years ago

Check for bugs in your audio chipset driver/kernel support.
If i remember right their are some bugs in Intel audio chipsets.

So i'm almost sure your issue is soundchip related.


Hammer459 9 years ago

Nice and clear description of each step