They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
gloriousigor
Score: 11
votes: 12
Format: Article

 How to Change Font Color on the Linux Mint Xfce Desktop


In Linux Mint Maya Xfce, if you choose a dark background, the desktop's black font suffers from lack of contrast. There is no GUI option for changing the desktop's font color. To get a light-colored font, perform the following steps:

Open Thunar, your File Manager, and navigate to /home/[your user name].

Click View and select Show Hidden Files.

Click on the now-visible default directory.

Edit as Root the file ".gtkrc-2.0".  What's that? There's no option in Thunar to edit as root? Well then, while we're here, let's take the time to add that option, because it is useful for many things besides just this project. In Thunar, click on Edit | Configure Custom Actions. In the window that pops up, click on the + sign to add a custom action. For the text, type in "Edit as Root", and for the command, enter : gksu gedit %f as this will open a file as Root. Click on the "Appearance Conditions" tab on the right and select Text Files and Other Files. Now you will be able to edit .gtkrc-2.0 as Root from within Thunar, so no more going to the command line just for that simple task. There is a minor glitch, however. Gedit will open up a second, untitled, empty tab each time you select this option, but it's easy enough to close that tab when you're done editing your file. The time saved opening in Thunar as root more than compensates for the second one will spend clicking [X] on the untitled empty file.

On a new install, .gtkrc-2.0 is almost empty save for one line or so. Append the following lines to make the desktop's font colors bright instead of dark, so that they look nice and sharp on a dark background.

style "xfdesktop-icon-view" {
XfdesktopIconView::label-alpha = 0

#Text colors you can delete these if you want you use gtk theme colors
fg[NORMAL] = "#ffffff"
fg[SELECTED] = "#00ff00"
fg[ACTIVE] = "#0000ff"

}
widget_class "*XfdesktopIconView*" style "xfdesktop-icon-view"

Save the file and you're done. You may need to reboot at this point to have your changes take effect. Better have a dark background already in place on your desktop, because the font color will be white by default and green when selected.


Tags: font,color,background,dark,desktop,xfce
Created: 2 years ago.
Last edited: 2 years ago.
Reviewed: 2 years ago.
Read 0 times.

Comments
11 months ago

jahid_0903014
nice tutorial  
1 year ago

CjTX2
Thank you for a double treat. I deal with the big annoyances in life, but the little ones just drive me nuts. I hated having to put a light panel on my dark background to be able to see the font. The "edit as root" tip just added a cherry on top of this much appreciated sundae. Keep up the good work.  
1 year ago

piyushdgr8
Great tutorial! Exactly what I was looking for.
Thanks gloriousigor
 
1 year ago

gloriousigor
Well, xfce is your lean and mean desktop, and it lacks nice features that are found in KDE. If you want a desktop that has everything Windows does and a lot more, then choose KDE. It is a mature desktop, but be warned it has a bewildering array of gui options, and it is possible (even likely) to make a change without understanding what that change does.  
1 year ago

BulldogDave
Excellent! I was going nuts trying to find the non-existent GUI option!

I think this needs to be addressed properly rather the handy solution provided here. It would seem a tad ridiculous to someone who has migrated from Windoze that Linux won't let you change font colour with ease.

Nevertheless, many thanks for the brilliant solution!
Cheers!
Dave.
 
2 years ago

gloriousigor
Thank you for your vote. It is nice to get above zero! ;-)
 
2 years ago

Slickness
Awesome!

Exactly what I was looking for.

Thank you!
 

Other tutorials from gloriousigor