They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
plaa
Score: 8
votes: 9
Format: Article

 Full Disk Encryption on Linux Mint 14


I tried installing Linux Mint 14 with full disk encryption using the instructions in the Full Disk Encryption easy HOWTO, but while I was able to follow all the steps, the system didn't boot after installation.  In Linux Mint 14, however, there's an even easier way.

The default installer for Linux Mint 14 does not support configuring full disk encryption, but a newer version of the installer does.  All you need to do it to upgrade the installer before you start the installation.

  1. Boot your system using the Linux Mint 14 live CD or USB stick
     
  2. Open a terminal and enter the following commands:
 $ sudo apt-get remove ubiquity
$ sudo apt-get update
$ sudo apt-get install ubiquity
$ sudo ubiquity

This will start the upgraded installer, which has the option of automatically configuring full disk encryption into use.


Tags: Full Disk Encryption, FDE, Linux Mint 14, Nadia
Created: 1 year ago.
Last edited: 1 year ago.
Reviewed: 1 year ago.
Read 0 times.

Comments
9 months ago

GreyFather
quickey , anyone tried this on latest linuxmint 16 cinnamon ofcos.. ill like to install it on second hard drive with full encryption  
1 year ago

Dave_Crane
Hi,

This was a great help, thank you. I've used it a couple of times, setting up Gnome/MATE, then the KDE version.

One suggested improvement - after removing ubiquity, the re-install tried to install the KDE front-end for ubiquity, which meant it downloaded a whole heap of packages (into a temporary RAMdisk I assume) - when I re-ran it as

# sudo apt-get install ubiquity-frontend-gtk

there was a lot less extra stuff downloaded.

If installing the KDE variant, then vanilla "install ubiquity" was fine.

Thanks again, Dave
 
1 year ago

sonia
Here's how you do it:
sudo su -
apt-get update
aptitude
# find ubiquity (use / for searching)
# remove ubiquity (use minus key), g g (go, go)
# find ubiquity (use / for searching)
# select it (press enter)
# select latest version (use + key), g g (go, go)
 
1 year ago

halyihev
Unfortunately when I do this, even with the apt-get update it just continually comes back with Ubiquity 2.10.16, it is not getting Ubiquity 2.12.16 which has the Full Disk Encryption option. I have verified that I've got a good internet connection, and it isn't throwing any errors on any of it. It's just only getting the old, incorrect version. Suggestions? Is there somewhere I can just grab the .deb file(s) I need?  
1 year ago

hpuntu
This doesn't work. This happens when I try it.

mint@mint ~ $ sudo apt-get remove ubiquityReading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ubiquity

Any idea what's wrong? I'm using Linux Mint Debian. Or does this not work on Linux Mint Debian? I thought LMDE used Ubiquity as well.
 
1 year ago

dude666
Did anyone of you get this working under Linux Mint 13?
I am running it in a VM with 40GB space, so it should be no problem at all. But I get this: http://pastebin.com/cpeqhcki
Any idea?
 
1 year ago

emtiu
Life saver :) Thank you so much!  

Other tutorials from plaa