They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
omns
Score: 31
votes: 35
Format: Article

 LMDE, intel, nvidia and compiz tips


A number of people have experienced problems with getting nvidia and compiz to work in LMDE. The following is a brief summary of successful techniques I've tried to get it all working on various machines.

First let me say that I like that LMDE comes without compiz enabled. It makes the live session really responsive and gives you something to think about when you have it up and running. Do you really need compiz at all if you don't use 3D? Gnome composting does a nice enough job if your answer is no. I can take or leave most of it but unfortunately I'm an absolute sucker for transparent menus. I can live without the rest.
 

Getting compiz to work with intel cards

sudo apt-get purge xserver-xorg-video-nouveau xserver-xorg-video-nv

sudo apt-get install libgl1-mesa-dri libgl1-mesa-glx

sudo dpkg-reconfigure xserver-xorg

Reboot or restart X :)
 

I've also been editing a script originally developed by ikey that does the same job. I'd be interested to know if there are any bugs with it. Testing at my end seems ok :)

wget http://omnsproject.org/scripts/intelfix.sh

chmod +x intelfix.sh

sudo ./intelfix.sh
 

My nvidia experience

The following is for the 17xx legacy driver but it should be a similar process for the 195xx driver as well. I'm not 100% sure what order I had to install these because of dependency issues but basically I installed the following:

nvidia-vdpau-driver nvidia-settings nvidia-kernel-common nvidia-xconfig nvidi-kernel-legacy-173xx-source nvidi-kernel-legacy-173xx nvidi-glx-legacy-173xx nvidi-kernel-legacy-173xx-dkms

I believe nvidia-kernel-common and nvidia-vdpau should be installed separately first, then the rest.

Before rebooting remove:

xserver-xorg-video-nouveau and xserver-xorg-video-nv

Reboot into new kernel then run nvidia-xconfig and nvidia-settings. Restart X.
 

Testing and starting compiz at logon ( adapted from this post at the LinuxMint forums ).

Test compiz is working by running alt-f2  then the following coomand:

compiz --replace

If that fails run the command in a terminal to get error messages.

Once you are happy with the way compiz is working create a new entry in startupp applications with the same command

compiz --replace

If you're feeling adventurous mmesantos1 and ikey have created a startup script that does a nicer job. Either method will work.

Create and add this script to your startup applications. Don't forget to make it executable.

#!/bin/sh
echo “Get Some”
if [[ `pidof compiz` ]]; then
# compiz running, nuke it.
metacity --replace &
killall -9 compiz
else
# no compiz.
compiz --replace &
fi

N.B. in LMDE the are no options set in the compiz control panel. You'll need to set these up to your liking :)


Tags: lmde intel nvdia compiz script
Created: 4 years ago.
Last edited: 4 years ago.
Read 26553 times.

Comments
3 years ago

Adidi
So mhwelsh what is the good solution for nvidia card now?
I tried with "apt-get install nvidia-kernel-dkms nvidia-xconfig" but the black screen makes me think that's not the good solution... :)
 
3 years ago

mhwelsh
9th July 2011.
LMDE'11'
The nvidia graphics card solution apparently no longer works.
Not all of the packages are still available and there absence seems to kill the new kernel build.
I will be glad to forward more details.

martin welsh
 
3 years ago

LONNIEFUTURE
It works with 64 bit i installed ubuntu-tweak with it a couple hours ago.  
3 years ago

bensoliman
this doesn't work with lmde 64bit, how do i get it to work?
cheers!
 
3 years ago

omns
@Silent_Warrior, hmm, I don't know why you'd want to run compiz in KDE nor why you'd want to add it to the KDE autostart. KDE is complete enough without adding compiz to it. I think that most people would understand that this tutorial is a designed for gnome.  
3 years ago

Silent_Warrior
Hm, no, loading the script on start-up isn't good for a Gnome/KDE dual-desktop system, at least when logging into KDE, and I was unable to hack a solution in. I half-assed a work-around: Disable the script, and put a launcher on gnome-panel pointing to compiz. I'll have to click it every time I log into Gnome (if I want the bells and whistlies), but it's just something I'll have to live with.  
3 years ago

digitsm
I should test "azathoth" method later and compare it with the ikey's method :D  
3 years ago

digitsm
I made the script mmesantos1 & ikey wrote above (namely thescript.sh), then made it executable by the code
% chmod +x thescript.sh
and added it to startup applications. Now works like a charm
 
3 years ago

Laurentiu
Very good  
3 years ago

ChirmiPlay
I added fusion-icon to the startup apps to get Compiz every time I turn on my PC.  
3 years ago

aiacomp
Very good !!!  
3 years ago

lleiria
It worked with the Intel card.
But when I run compiz --replace on the terminal, I receive the following error messages:

WARNING: Application calling GLX 1.3 function "glXDestroyPixmap" when GLX 1.3 is not supported! This is an application bug!

and

compiz (cube) - Warn: Failed to load slide: /usr/share/images/desktop-base/debian-blueish-wallpaper-640x480.png

what is it all about?

Thanks
 
4 years ago

azathoth
For starting compiz seamlessly, what has worked very well for me is adding:
export WINDOW_MANAGER=/usr/bin/compiz
to ~/.gnomerc
(I think I had to create it if I remember right.)
 
4 years ago

rufong
intel card, my only deviation from your instructions, afaik
was enabling gnome compositing a few days ago, before trying thy how-to..


./intelfix.sh: line 17:  : command not found
 
4 years ago

omns
I don't have an ATI card to do any tests on but this forum post may help :)

http://forums.linuxmint.com/viewtopic.php?f=141&t=55159&p=319935#p316016
 
4 years ago

siz182
Any advice on ATI cards?  
4 years ago

Deadguy
very nice omns.  
4 years ago

racklin
Install fusion-icon and add to start up session is easier then
writing script. BTW, Nice Post!
 
4 years ago

shantorn
This worked for my laptop flawlessly. Thanks  
4 years ago

remoulder
Nice post  

Other tutorials from omns