They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
ron_o
Score: 10
votes: 22
Format: Article

 How to get Nvidia's proprietary driver to work


This is a simple tutorial to help you get the Nvidia proprietary driver to work on Linux Mint 9 (Isadora) using Grub2.



Part I (Why)


The open source community has decided to create their own open source video driver for Nvidia video cords, called Nouveau.  Nouveau is compiled into the kernel and while running isn't compatible with the proprietary Nvidia drivers. Stopping the module after the system boots has proven futile. What does work is blacklisting it via a kernel option upon boot.




Part II (How)

 

  1. I followed this guide to get mine working, written by ferro. I've added a few things here that might need further explanation.   
  2. Note: Run commands as sudo and back up or make notes of what you change.
  3. Open   /etc/default/grub  and change:      GRUB_CMDLINE_LINUX_DEFAULT="nouveau.blacklist=1 quiet splash"                            Specifically add "nouveau.blacklist=1" to whatever you have. It will probably look like the above.
  4. Run: $ sudo update-grub2
  5. Reboot
  6. After the reboot you'll be promted to run in low graphics mode. Accept it and sign into your account.
  7. Install the Nvidia hardware drivers as you normally would through "Hardware Drivers" in the Menu.
  8. Run: $  sudo nvidia-xconfig   
  9. Restart X : Alt+Ctrl+Print_Screen+K. This should restart X but if it doesn't then restart your computer
  10. Your screen should look like like your video card is working.
  11. To see if Nvidia is recognized: $ inxi -xG      OR:
  12. Menu >>  Nvidia X Server Settings and you should have options show up with no reported errors.


Good luck.

 


Tags: Nvidia, Driver, Nouveau
Created: 4 years ago.
Last edited: 4 years ago.
Read 7063 times.

Comments
4 months ago

severoon
I'm running Mint 17 Cinnamon 64-bit, these instructions are out of date. This worked for me - http://www.binarytides.com/install-nvidia-drivers-ubuntu-14-04/

Immediately after the step:
$ sudo apt-get install nvidia-###

Reboot. Nouveau is automatically blacklisted and you should be good to go.
 
5 months ago

nicos
Mint 17 Cinnamon 32 bit
The instruction was somehow helpful but there were a few error messages: "Skipping the runlevel check utility runlevel failed to run." "The distribution-provided pre-install script failed...."
Result: The NVIDIA driver runs only in the recovery mode. Further suggestions would be appreciated.
 
1 year ago

fufu001
Mint 15 Cinnamon 64 bit
This tutorial worked great for untangling my hanging system. I had already switched to the proprietary driver using "Driver Manager". After rebooting, the desktop started to look scrambled, starting with the update manager in the system tray and spreading to other screen elements, rapidly coming to the point where the whole system was unresponsive.

Following alkadia's steps up to the "update-grub" step in recovery mode worked for me.

Thanks alkadia & ron_o!
 
1 year ago

alkadia
Hi,
after 1 day of work finally I have successfully installed latest NVIDIA driver on Mint 15 cinnamon 64bit.
All the hints on this discussion had contributed to help me so I try to put order.
In my case the GPU is a ION GT218 on an ASUS eeePC.
Start Mint in recovery mode so the mdm will not run.
Select Root in the menu or go to shell as root.
Remount the / in read and write mode :
#mount -o remount,rw /dev/sda1 / (in my case root filesystems is /dev/sda1)
Now edit /etc/default/grub and apply the change suggested above :
GRUB_CMDLINE_LINUX_DEFAULT="nouveau.blacklist=1 quiet splash"
Remeber to update the grub with :
# update-grub
or comeback to recovery menu and select the "grub" option.
Reboot
Start again in recovery mode and select "root" option. Unload "nouveau" module :
# rmmod nouveau
now you can install "nvidia drivers" in my case :
# NVIDIA-Linux-x86_64-319.23.run
Perhaps the installation procedure will add the file "nvidia-installer-disable-nouveau.conf in /etc/modprobe.d for blacklist the nouveau module, in that case you will reboot again the PC.
Don't forget to : start in recovery mode ; select root; remount / in RW and run again NVIDIA-Linux-x86_64-319.23.run
I suggest to compile the nvidia module in DMKS and it will be automatically recompiled if the kernel will be upgraded
Let me known if something is wrong
Bye
 
1 year ago

chemtv
oh BTW, I am using a quadro card with a viewsonic monitor that is connected with a dual link DVI-I cable. This setup works fine at work (but we are running ancient 2.6.18 distro's there)
Thanks
 
1 year ago

chemtv
This does not work for me. Nouveau has it's tentacles into so many places I can not seem to squish all of them. I want the graphics to drop into text terminal mode (eg. like use vesa) I can see in my Xorg.log that vesa is loaded, BUT something keeps unloading it and then loading nouveau. The result is a black screen with no text... I have to ssh in from another machine, re-edit my grub file and put things back just to look for the next (non) solution. This is driving me nuts. All I want to do is to kill nouveau completely, run basic terminal text graphics and then LOAD the nvidia drivers! Whay does this have to be so hard?? Thanks for any help!  
1 year ago

tarkk
Thanks Ron... very helpful..  
1 year ago

BrezenSoiza
Outdated for Mint 14.

GRUB_CMDLINE_LINUX_DEFAULT="nouveau.blacklist=1 quiet splash"
This change still starts the graphical surface for me.
 
1 year ago

zbyna
It helped. Thanks mate.  
2 years ago

nuevousuario
After the reboot.. nothing happens!!  
3 years ago

leugene
Work perfectly :) Thank You!  
3 years ago

Medmehdi
Thank you for this tuto, it was very helpful :D  

Other tutorials from ron_o

No other tutorials.