They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
LifeInTheGrey
Score: 2
votes: 13
Format: Article

 Compiz in LMDE


Hey all, I realize there are a couple different resources that show you how to install and set up Compiz in LMDE, however they are a bit patchy and confusing, plus they all rely on fusion-icon at startup! This is very inefficient because the Window Manager first boots into the default Metacity, and then needs to reboot with fusion-icon starts, so it hurts both free memory and makes boot time longer. I figured I would provide a simple tutorial that will elegantly make Compiz run at boot without the need for fusion-icon. This information is also available in my tutorial about how to set up LMDE based on Debian Stable repos located here: http://community.linuxmint.com/tutorial/view/497

 

So, lets start from scratch:

 

1) Install remaining Compiz components

- Type this into Terminal:

 

sudo apt-get update && sudo apt-get install compiz compiz-fusion-plugins-main compiz-fusion-plugins-extra compiz-fusion-plugins-unsupported

 

- You can leave the unsupported one off if you'd like, its not really necessary, it just gives more goodies.

 

2) Configure Compiz 

 

***VERY IMPORTANT - YOU WILL NOT SEE EFFECTS ON REBOOT, AND YOU WILL NOT SEE ANY TITLE BAR AT ALL, UNLESS YOU DO THIS***

 

- Go to Menu => Preferences => CompizConfig Settings Manager

- Check everything that you would like to include. I personally checked stuff like Wobbly Windows, Desktop Cube, 3D Windows, etc.

- However, you MUST check "Window Decorations", otherwise the windows won't have a title bar on them when you restart! Quite upsetting.

 

3) Set Compiz to start at boot

- Now, to the good stuff. Type this into terminal:

 

gconftool-2 --type string --set /desktop/gnome/session/required_components/windowmanager compiz

 

- Hit enter. You won't see anything happen in terminal, but don't panic ... all it does is modify the file to start Compiz at boot instead of Metacity. Even though there is no confirmation, you are good to go.

 

4) Reboot.

- Simple but important aspect; Compiz is set on boot, so you need to reboot for it to be set! Once you do, you'll start seeing all those fancy effects everyone loves.

 

Bam, a clean and elegant Compiz setup that would make momma proud. She is an LMDE user, right? :)


Tags: LMDE Compiz
Created: 2 years ago.
Last edited: 2 years ago.
Reviewed: 2 years ago.
Read 521 times.

Comments
1 year ago

supri
why in my linux mint debian compiz not found?
 
1 year ago

elvis_ef
Yeah.. You're right but what about Mate desktop environment? I tried tricks You wrote, but this doesn't work for me. In Mate there is an editor with a changed name to "mateconf-editor". When I changed the values for gconf, that didn't work. When I changed it for mate editor - worked partially - the problem was: no window decorator active (windows decorator wasn't applied). I looked for a simple option for changing window decorator automatically while booting the system, but there was no similar to window manager one. Maybe You know any trick to make this work?:)

PS.Yes, I have Decorator Window active in Compiz settings manager (like I wrote earlier, I checked all Your suggestions).

Thanks in advance,
Elvis
 
2 years ago

LifeInTheGrey
Well ... yeah haha. The reason I didn't include those extra programs was because back when I made this tutorial, they were already installed in the system. And the only one you need to check is window decorations, the rest are obviously optional.

You CAN start compiz with "compiz --replace" in startup programs, but by doing that you basically you start Metacity, then once booted you start Compiz using your startup programs ... meaning you start a window manager you never intended to use before then killing it and replacing it with the one you want. You're obviously welcome to do whatever you like, but you are uselessly wasting additional boot time and system resources for no reason other than to say "I did it a different way and it works for me".

Just sayin.
 
2 years ago

metnoc
Hi, I did

sudo apt-get update && sudo apt-get install compiz compiz-fusion-plugins-main compiz-fusion-plugins-extra compiz-fusion-plugins-unsupported compizconfig-settings-manager

marked "window decorations"

added "compiz --replace" in startupprograms.

Reboot.

Works for me.
 
2 years ago

LifeInTheGrey
Thats because the Mint repo pulls from Debian Testing, which is still on 0.8.4, even in Sid. If you want a newer version of Compiz, you can install the Main Edition (Ubuntu has a Compiz ppa that uses higher versions, up through 9 beta I believe), or you can compile it from source to be used on LMDE. Sadly, those are the only options. :(  
2 years ago

claus0123
but the login process is abit slow. I have a Core Duo with 4 Gig RAM laptop using 0.8.4 compiz.

anyone tried the 0.8.6 or 0.8.8? seems like I can't get it from the mint repo.

 
2 years ago

LifeInTheGrey
Happy to be of service!  
2 years ago

theremper
thanks exactly what I was looking for. Easy to follow  
2 years ago

LifeInTheGrey
Ah, sorry to nag, but most likely you didn't read the MUST section, where you MUST check the box for "Window Decorations"! You should still be able to open CompizConfig Settings Manager, so go in there and check the box ... the title bar should magically appear. :)

I'll also make it a bit more obvious on my tutorial.
 
2 years ago

kazztan0325
I want to make Compiz work on LMDE, tried according this tutorial.
But...,Compiz still doesn't work, and moreover, Title bar and Flame of the Window have disappeared!!

I don't know when and how did I mistake...
 

Other tutorials from LifeInTheGrey