They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
tux-sven
Score: 50
votes: 54
Format: Article

 How to activate Compiz in Mint 13 Maya MATE


There is some things you have to do to get Compiz work.

  • Install the packet "compizconfig-settings-manager".
     
  •  In a terminal window write "compiz --replace"     (When you want Compiz start automatic you can open Control Center -> Startup Applications, and add a new post "Compiz" keeping the same command "compiz --replace".
     
  • The CPU usage now raises a lot.  That is because there is two competing window-managers running.

To stop that high CPU usage in MATE when running Compiz:

  • In a terminal type “mateconf-editor
     
  • When the editor opens:
    Go to /desktop/mate/session/required_components/windowmanager and replace "marco" with "compiz".

Not much happens now,

Thats because nothing is checked in "Compiz Configuration Settings Manager". 

 

  • Open the Compiz Configuration Settings Manager.

    Check what compiz-functions you want to activate.

    One you sure need, the "Window Decoration".

    Then you can choose "Move Window" and things you find good for you.


Myself I have activated Desktop Cube, Rotate Cube and Wobbly Windows.

Note that the number of windows are set in "General Options" -> Desktop Size.

I also think the desktop zoom is very nice, but at the moment I have not succeeded in activating it in the same way as LM 10 Julia.
 

Please also take a look at the comment from jse654 and the others.  Their comments can be  very informative and useful for you.


Tags: Mint 13, Maya, MATE, Compiz
Created: 2 years ago.
Last edited: 2 years ago.
Reviewed: 2 years ago.
Read 0 times.

Comments
1 year ago

tux-sven
The Anarchist:
I am running LMDE at the moment. In LMDE Enhanced zoom is working in the same way as in LM10. I just press the Super-key (the ugly one with a win-flag) and use my mouse-wheel for step-less magnifying. It works nice everywhere, with center at the mouse-pointer. I will perhaps, later, try to get it work in the same way in LM14 or LM15. :)
 
1 year ago

The_Anarchist
tux-sven, My eyes aren't very good so I also like the desktop zoom. What did it for me is. Under Accessibility's > Enhanced Zoom Desktop is clicked and Zoom In for me is Button4 and Zoom Out is Button5. I hope this helps.  
1 year ago

HeshamSL65
Thank you very much for this guide, I succeeded in running Compiz on Mint Maya and to fix some minor issues, which for me were the Window Decoration, Mouse Pointer, and some Focus Problems. Here is what worked for me:
- Installed Compiz Fusion (apt-get install fusion-icon compiz-fusion-plugins-main compiz-fusion-plugins-extra)
- Putted fusion-icon in Start Up apps (instead of suggested `compiz --replace`)
- Changed the key windowmanager from macro to compiz in mateconf-editor
- Installed gconf-editor
- Opened mateconf-editor @ apps/marco/general/theme & gconf-editor @ apps/metacity/general/theme side by side and copied values from mateconf to gconf, this sets the Theme and fixes the ugly default Window Decorator.
- I like the DMZ-Black mouse pointer, so I used `sudo update-alternatives --config x-cursor-theme` to apply it
- To open the usual Alt+F2 Run Application dialog, I used the helpful C code at http://forums.mate-desktop.org/viewtopic.php?p=1461#p1461 to compile a simple executable which can later be assigned with Alt + F2 from CCSM -> Commands -> Key Bindings)
- I had some Focus problem in that some windows didn't opened focused when they get opened, I fixed this by Setting Focus Prevention Level to Off in CCSM -> General Options -> Focus & Raise Behavior

I hope Compiz proves to be stable with Maya.
 
1 year ago

andreya
how to activate burn effect animations on compiz?
i already install compiz-fusion-plugins-extra
but still no burn effect animations
 
1 year ago

guyfromkcmo
Thank You Very Much! :) @tux-sven
-- I've just changed over to Mint Maya with MATE from Ubuntu 10.04 LTS - GNOME 2.0 with Compiz. I had everything the way I liked it... I hate change (not a useful character trait in the computer/tech world...) I will reluctantly adapt, but NOT TO Unity Interface... blech! I like -MATE & the Desktop Metaphor -dagnamit *cough* "get off my lawn" :^p
 
1 year ago

Abderraouf
thank you :)
شكرا لك
but he make problems with 14.1 and when recise the window cant move it
 
1 year ago

Abderraouf
thank you :)
شكرا لك
 
1 year ago

willerman
Thx for the nice tutorial!!

Just successfully made compiz the default window manager again. For my installation (Mint 13 MATE) it is even sufficient to make compiz the default window manager in the MATE conf editor- I didnt even have to add compiz to the startup applications!

BTW: Does anyone know why compiz has been replaced with marco as the default window manager?
 
1 year ago

SilentThunderStorm
Nevermind!

Got it all solved.

For those missing title bars, etc... go to ccsm, click 'Preferences' towards the bottom, and check 'Backend' to see if it is pulling its config from Flat File (mine was, and apparently, that is default.. why? I dunno...)

Change this setting to 'GSettings Configuration Backend', which will integrate it to the desktop.

Now on the main screen of ccsm, enable 'Window Decoration', 'Move Window', 'Resize Window', etc.

On compiz --replace, you should have a fully functioning desktop again.

Still looking for the extra effects, if anyone knows how to get them... specifically 'Cube Deformation and Reflection'.

 
1 year ago

SilentThunderStorm
OK... followed the directions, including activating 'Window Manager' under ccsm, AND installing fusion to handle window management.

So far, there is no window management functioning on the system under Compiz. This includes the top bar (close, minimize, etc) as well as being able to drag or resize windows..

Using a fresh install of Mint 14 with Mate (as of like 5 minutes ago + time messing with it), the ccsm that shows up in repo (0.9.8.5), no clue on the fusion version...

Additionally, I cannot seem to find several options that I used to use... specifically Cube Deformation and Reflection, and several other effects plugins. They do not seem to appear at all on SoftWare sources? Am I missing a PPA?

Biggest concern is the Windows Management... without it, I have to go back to Marco... the rest will follow in time.

Any ideas?
 
1 year ago

tux-sven
Yes it works in Mint 14 also. No flickering when turning the cube. :)
But I can see another Compiz-problem has appeared on my computer (Acer Aspire One):
The cube gets distorted during the turning. It seems almost like wrinkles at the cube side, or something similar to that.
I can't find any way to solve it either.. :(
 
1 year ago

germulvey
Worked in Mate 14 too :)  
1 year ago

David87
Thanks. works  
2 years ago

sunmake
@mpiter
Thanks for your working advice.But Gnome Configuration Editor (gconf-editor), is not installed by default.Must be install separately, and then can be found in System Tools.
 
2 years ago

GMarco24
I did everything like in this tutorial, but I got problem with compiz. It doesn't save any options I check.
I am using amd radeon 7770 with additional drivers for it (latest). Could that be a problem?
Thanks
 
2 years ago

jcm1107
I am having some trouble getting compiz to work. I am new to mint just swiched from using ubuntu.
I followed the above tutorial and nothing happened and I know in ubuntu you sometimes have to log out and back in so I did and then had a flickering screen where I believe compiz and marco?(stock mint manager?) were both running at the same time. I opened a terminal typed compiz --replace and it stops the flickering but my efects do no take place either? I have an nvidia motherbord no graphics card using nvidia recomended drivers. I also followed jse654's sujestions and they didn't work unless I didn't do it right?
pleas help as I am too used to my cube :)
 
2 years ago

mpiter
Finally, @tux-sven

Great tutorial. I used it several times for several computers or OS that I tried. I have already given the link to your tutorial in several forums to help people in difficulty with Compiz. Thanks a lot because I would not have thought about replacing marco by compiz in the mateconf-editor.
 
2 years ago

mpiter
@sunmake

To change window decoration in Compiz, run the Gnome Configuration Editor. Do not use the Mate Configuration Editor if you run Mate because it will not work. You will find the Editors in the Linux Mint menu "System tools/Configuration Editor". Select the Editor with a grey icon, not the red icon.

In the editor, select "apps/metacity/general/theme" and put any theme value you like for the Window border. For example, I like bit buttons so I choose ClearlooksRE that many people will find ugly but I think it handy.

As you can see, you can build your window border with the variables contained in "apps/metacity/general". For example, I like to have the menu on the left, the Minimize, Maximize, and Close buttons on the right. Furthermore, I like to have the Close button separated from the two others to avoid to accidentally kill a window when I want to maximize it. So I set the "button_layout" variable to "menu:minimize,maximize,spacer,close" without the quotes. Good luck.
 
2 years ago

mpiter
A Compiz version without the flickering bug has been provided in a PPA. Unfortunately, a newer Compiz version with the bug back has recently been placed in the Ubuntu software tree. As a consequence, any system update will select the new Compiz version instead of the PPA one. So the solution to get rid of the flickering bug is to add the PPA to the software sources, to force the PPA Compiz version installation, and to block any Compiz update. With the Compiz update blocked, it becomes the user task to manually check when a new Compiz version will be available. Keep the 23th of August in mind, something may come out that day or soon after.

The solution I am going to summarize comes from https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/862430.

sudo add-apt-repository ppa:vanvugt/compiz-preproposed
sudo aptitude update
apt-cache show compiz | grep Version: | awk '{ print $2 }' # to identify
# the name of the preproposed version if you have doubts
sudo aptitude install compiz=1:0.9.7.8-0ubuntu1vvpreproposed2 compiz-core=1:0.9.7.8-0ubuntu1vvpreproposed2 compiz-gnome=1:0.9.7.8-0ubuntu1vvpreproposed2 compiz-plugins=1:0.9.7.8-0ubuntu1vvpreproposed2 compiz-plugins=1:0.9.7.8-0ubuntu1vvpreproposed2 compiz-plugins-default=1:0.9.7.8-0ubuntu1vvpreproposed2 libdecoration0=1:0.9.7.8-0ubuntu1vvpreproposed2
compiz --replace

To block Compiz updates, go into your update manager, right-click each Compiz package, and ask to block the package update. This will update the /etc/linuxmint/mintupdate.ignored file.

If you have an Nvidia card, more bugs will be triggered by the fix, but on my laptop with an Nvidia Quadro FX 1800M, Compiz is pleasant again. I am happier with the PPA version.
 
2 years ago

mpiter
The flickering and the rotate with window bugs (SHIFT+CTRL+ALT+[left/right]arrow) are known, fixed, and committed. The fix has not been included in the last Compiz releases because it triggered new bugs. See https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/862430 for the bug description and https://bugs.launchpad.net/compiz/+bugs?field.tag=compiz-r3110-regression for the list of bugs triggered by the fix. The Compiz team decided that too many bugs were generated by the fix to distribute it. Since most of those bugs have already been fixed, they plan to distribute the correction in Compiz 0.9.8 with Ubuntu 12.10. If we are very lucky, the fix might be included in Compiz 0.9.7.10 planned for the 23th of August, but I am not sure whether it will be done before Ubuntu 12.10. The fix is however available in a PPA. I will explain how to install it in another post.  
2 years ago

sunmake
Great tutorial,but I stuck with 'AgingGorilla' window boarder. Changes simply not apply. Any solution?  
2 years ago

cowsquad
Great:-) I just followed this tutorial and compiz is working flawlessly  
2 years ago

tux-sven
Recently it was an Compiz update which I expected much from. However I have to report it didn't solve the flickering problem at all... :(  
2 years ago

bkidwell
Great Tutorial... could not have done it without this!
However...
One problem I'm having is that when fade back using expo, the movement of windows from one desktop to another is incredibly glitchy, they may move or not, and sometimes wholes windows disappear. The same is true when I try to move with ctrl-alt-arrow on the desktop wall. Somtimes it works, mostly it is glitchy and the window remains on the previous desktop. With some trial and error I have determined that this can be fixed if the Place Windows is disabled in Compiz... this is a rather unfortunate workaround though, as windows now are placed behind the panel. Any help or suggestions?
Thanks so much!
 
2 years ago

losalamos
Hi tux-sven and thank you for a great post (with the help of jse654, and kazztan0325 idea about the icon), it basically works. Since I'm new to Mint, I kind of do not understand why "Gnome Compatibility" does nothing about ALT-F1 and ALT-F2 shortcuts - they still do not work under Compiz.

Another quite annoying thing is about window borders - they do present, but turn in to something not too pleasant to look at.
Do you know any workarounds?

PS After changing window manager to Compiz, I had manually to add ALT-CTRL-T shortcut in order to start Terminal, althought it's already there in Marco.

PPS It's fun to set under Desktop Cube - Transparent Cube - Opacity During Rotation to let's say 50,000.
 
2 years ago

tux-sven
@ hurinth:

Install Compiz Fusion Icon and try to manage Window Decorations from there.
 
2 years ago

hurinth
Hello, Great post, anybody knows why after starting compiz --replace window borders go away? I am choosing the Window Decoration option within CCSM, but it doesnt seem to take effect. Each time I login my previously selected options are uncheked, and window borders do not work. This is Mint13 64bits with Mate and nVidia drivers enabled. Any ideas will be greatly appreciated.  
2 years ago

tux-sven
@ Senanito:

I also run LMDE-MATE with Compiz. In LMDE there is no problems at all with Compiz. It runs perfect as far as I can see.

I think the issues in LM 13 depends on bugs in actual version of Compiz (or Ubuntu.)
 
2 years ago

Senanito
cool, will try, but i'm afraid there will be some conflict between mate and compiz... are you sure they will work normally together?  
2 years ago

Anderxale
Very useful thanks  
2 years ago

efthialex
Great tut Sven!  
2 years ago

SidharthaXx
Just an update. Sadly compiz has unexpected crashed on me two days in a row now. Actually while using compiz settings. Doesn't quite feel ready for prime time to me. Back to Marco sadly ;-(

Thanks for all your help.
 
2 years ago

phsilver
Hi...
I've recently instelled Maya on a Quad core 2800 mhz Intel Processor, Nvidia GeForce 7200SE graphic card...
Everything works fine but the nvidia 3d capabilities.
I can't make this work frome the Restricted Hardware Driver Window... It returns an error: something with a file locked.
Obviously, I can't run Compiz...
Which drive should I manually have to install? (If it's possible...)
Thanx!!!
 
2 years ago

SidharthaXx
Sorry, one more question... I no longer seem to be able to change my window borders. Is there something I need to change...? Thanks  
2 years ago

SidharthaXx
Although one thing that does seem to have changed under compiz is that now my conky has a border around it rather than simply merging into the desktop. Anyone else had this...? Thanks  
2 years ago

SidharthaXx
Ok, so I finally got this working. Thanks for your patient input!
Finally the thing that worked for me, was changing marco to compiz... logging out and logging in again... putting up with some strange window effects for a couple of minutes until I ran compiz --replace in the new session terminal...

Now compiz seems to be working nicely without the high CPU...

Thanks again
 
2 years ago

tux-sven
The flickering issue when rotating the cube, is due to a bug in Compiz.
See: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/876198
You can wait for an update or install previous release of Compiz to get rid of it.
 
2 years ago

tux-sven
@ SidharthaXx:

Do you really log-in as a normal user? (You don't use auto-login?)

To me it sounds like you didn't have the right privileges to change settings.
 
2 years ago

SidharthaXx
Hi,

Yeah I did quadruple check. Funny thing is, the step where I change the setting in mateconfig-editor from marco to compiz... actually it doesn't seem to make any difference at all to CPU usage what I have in there. If I change it to compiz, or if I leave it as marco I get the high cpu usage. It's the act of running compiz --replace that kicks off the cpu.
It's almost like the changes in mateconfig-editor haven't made any difference. Just to check, there is nothing I need to do after changing from marco to compiz to make that change take effect?

Many Thanks
 
2 years ago

tux-sven
@ SidharthaXx:

Did you really follow the step "To stop that high CPU usage in MATE when running Compiz" from above?? Sounds strange to me. Check what is set in matecof-editor once more, just to be sure.
The CPU usage might be a slight higher when Compiz is activated, but not at that size you mention. At the time I have no other ideas, sorry.
 
2 years ago

SidharthaXx
Hi guys,

Thanks for the tutorial. I have everything working nicely. However, I have noticed that my CPU is significantly higher. Before compiz it's literally idling around 2-3%, after compiz starts I'm up to 23% ish... and yes I have changed from marco to compiz using the “mateconf-editor”...

is this normal? Any ideas?

Many Thanks
 
2 years ago

kazztan0325
EDIT on my pre-previous post:

"As for changing window decorator, if we could install Emerald, we would be able to change window decorator between Emerald and Compiz."

This sentence should be...
"As for changing window decorator, if we could install Emerald, we would be able to change window decorator between Emerald and GTK Window Decorator."

Sorry for my slip of the pen (actually I should write "the keyboard", not "the pen" (smile).)

 
2 years ago

kazztan0325
You are welcome, @Mandler !
I am happy to hear you have solved your problem.
Cheers!

 
2 years ago

Mandler
@kazztan0325: Great suggestion about fusion-icon. It's very convenient. Also, in my case, although I was able to use this post to see the Compiz settings, and although Compiz was shown as the active Window Manager in the fusion-icon menu, it actually wasn't. Using the fusion-icon menu, I could easily switch to Metacity and back to Compiz to solve the problem. Thanks.  
2 years ago

Mandler
Worked perfectly. Would have never figured it out on my own. Thank you.  
2 years ago

Lopau
It worked for me just like in the tutorial of tux-sven.
Just one question: I really don't like the decoration of the top bar, is there any way to change it (font type and buttons)?
 
2 years ago

xfirebg
@ kazztan0325
"But unfortunately there is not the package 'emerald' for MATE at present."
Yes, this is very strange.
 
2 years ago

kazztan0325
@tux-sven:
"Your suggestion is that the Fusion-icon makes it possible to start and stop Compiz whenever you want during the session?"

Yes, we can switch between Compiz and Metacity during the session just by clicking on the pop-up menu of Fusion icon.

As for changing window decorator, if we could install Emerald, we would be able to change window decorator between Emerald and Compiz.
But unfortunately there is not the package 'emerald' for MATE at present.

 
2 years ago

tux-sven
@ kazztan0325:

Thanks for your post.

I tested the Fusion icon early, because I wanted to see if it was possible to change window decorator. But I was suprised, there was only GTK-theme to select. After that I have done nothing about it.

Your suggestion is that the Fusion-icon makes it possible to start and stop Compiz whenever you want during the session?

I will test that a bit more when I am on Mint 13 again. (Normally I run Mint 10)

 
2 years ago

kazztan0325
@tux-sven:

What do you think about my comments which I posted here 2 days ago?
 
2 years ago

tux-sven
@ hufter:

Sorry I think you can't get it to work as nice as in Mint 10.

"However it still annoys me that whenever I change the viewport, the previous viewport flickers on screen just when the change has finished."

Yes that also annoys me a lot. It has to do with when windows gets focus I think.

I have not found any solution for that. :(

The moving window-problem I fixed by un-checking somewhere. I can't remember exactly what menu it was at the moment.

I am sitting with my Mint 10 just now so I can't look for it.
 
2 years ago

hufter
Thank you, this really helped. I've missed Compiz, could not get it working properly since Mint 10.

However it still annoys me that whenever I change the viewport, the previous viewport flickers on screen just when the change has finished. Also I cannot move a window to another view with Ctrl-Alt-Shift-arrow. The window looks like it's moving, but after the flicker it's still in the previous workspace.
Any fix for this?

I have a NVidia GT 430 based card and NVidia's proprietery driver seems to be working.
 
2 years ago

xfirebg
@ tux-sven
Thanks
 
2 years ago

jse654
Thanks again, Sven.

***Warning***, in my long post below, the word Super (for the Super/Mod4/OS key) got deleted. (I had the word in angle brackets.) Don't use only the equal, minus and zero keys for the zoom function. Use the Super key with them.

Here is the corrected version.

Under Enhanced Zoom Desktop, it should say:

I had to setup the keybindings for this:
Click on "Enhanced Zoom Desktop" button.
In Zoom In/Out tab, click on "Disabled" button for the keyboard - Zoom In setting.
Click on "Enabled" checkbox.
Click "Grab key combination" button.
Press Super =
In other words, hold down the Super key, and press the equal key.
(The Super key is also called the Win/Mod4/OS key.)
Click "OK" button.
Do the same for keyboard - Zoom Out using Super -
Do the same on the "Specific Zoom" tab for "Zoom Specific Level 1" using Super 0
The latter restores the screen to a non-zoom (100%) state since the zoom factor is set to 1.0000.

I just noticed this. Sorry for any confusion, folks.
 
2 years ago

kazztan0325
@tux-sven:
Thank you for your tutorial, it solved my problem.

By the way...,
There is a package 'fusion-icon' in Mint repo.
I think it would be more easier and more useful for users to install 'fusion-icon' and add it to "Startup Applications" instead of adding a new post "Compiz" to there.
We would be able to switch window decorator / reload window manager / launch CCSM when we right-click on 'fusion-icon' in notification area of panel.

I think that of course you know about what I wrote above.
I am wondering why you did not make mention of 'fusion-icon'.
Is it possible to cause any problems on specific video cards/chips?

 
2 years ago

tux-sven
@ xfirebg:

I think you only got one window decorator in this version. Someone named "Bill" succeeded in adding the "Emerald" decoration but I think i was rather complicated. I don't try to do anything around it myself, because I mainly run an updated LM 10, still. LM 10 is outstanding in all aspects I think. :)
 
2 years ago

tux-sven
@ fudo 729:

You must acivate "Window Decoration" in the Compiz Configuration Settings Manager.

Also take a look att the comment from jse654. It's a very good one! :D

/Sven
 
2 years ago

jse654
Sven, thanks for this tutorial. It definitely got me going with Compiz.

On my Nvidia system, Compiz does not work perfectly, but pretty good. Among other things, it got rid of a couple keyboard shortcuts, like Ctrl-Alt-t for Terminal (which was set up automatically by marco, apparently) and Alt-F1 to show the panel's main menu. I reinstated Ctrl-Alt-t in Menu | Preferences | Keyboard Shortcuts. In fact I now use Ctrl-Alt-y also since Compiz requires a little different geometry for where I want to place the window.

I don't suggest typing "compiz --replace" in a terminal. This worked for me but stalled mid-process at "Initializing core options...done," until I used the mateconf-editor to change the WM to compiz. At that point, "compiz --replace" resumed, but finished with a bunch of warnings and a "Segmentation fault."

Instead, I suggest you:
- set the options in Compiz Configuration Settings Manager first (see below), then
- put "compiz --replace" in Startup Applications, then
- change the WM (see below for a quicker way), then
- logout and login.

I know a WM is supposed to be able to be changed without a re-login, but on my system this seems to be a much more stable way to do it. If anyone has further info on this, I'd love to hear it. :)

To change the WM on the command line, use one of these:
mateconftool-2 -t string -s /desktop/mate/session/required_components/windowmanager "compiz"
mateconftool-2 -t string -s /desktop/mate/session/required_components/windowmanager "marco"

I put these into my ~/.bashrc file as functions for easy usage.

Here are the Compiz settings I am using. This should be a decent place to start for someone who is unsure what options to use. Some of the plugins get set by default. (When setting certain options, a dialog popped up asking if I wanted to install other, required plugins: Say Yes. :) Click on the check boxes next to the following options:

Composite
OpenGL
Rotate Cube
Window Decoration (very important, like Sven said)
Wobbly Windows
Compiz Library Toolbox
Mouse position polling
Move Window (important)
Resize Window (important)
Shift Switcher (Alt-Super-Tab)

Enhanced Zoom Desktop
I had to setup the keybindings for this:
Click on "Enhanced Zoom Desktop" button.
In Zoom In/Out tab, click on "Disabled" button for the keyboard - Zoom In setting.
Click on "Enabled" checkbox.
Click "Grab key combination" button.
Press =
(The Super key is also called the Win/Mod4/OS key.)
Click "OK" button.
Do the same for keyboard - Zoom Out using -
Do the same on the "Specific Zoom" tab for "Zoom Specific Level 1" using 0
The latter restores the screen to a non-zoom (100%) state since the zoom factor is set to 1.0000.
(These are the zoom-in/out/100% keys KDE uses by default on LM12-KDE.)

Desktop Cube
The "Unfold" option (Ctrl-Alt-DownArrow) messed up my system by slowing it *way* down. (Workaround: logout (possibly by force with Ctrl-Alt-Backspace), then login.) So I disabled it:
Click on Desktop Cube button.
Click on General Tab.
At Unfold, click on Down button (the default shortcut button).
Uncheck Enabled checkbox and click OK button.
Also, I changed the Top and Bottom Cube Cap Colors in the Appearance tab. (Man! Does Compiz have a ton of settings, or what!?!)

Static Application Switcher (Alt-Tab)
(Application Switcher is a different option and conflicts with Static Application Switcher. Application Switcher didn't work on my system. I had to logout, login a few times when first trying it.)

Click on General Options. On Desktop Size tab, set:
Horizontal Virtual Size to 4,
Vertical Virtual Size to 1, and
Number of Desktops to 4.
This allows the cube shape which can be seen with Ctrl-Alt-mouse-drag-and-drop.

YMMV. Enjoy. Hope your Compiz adventures go well. ;)
 
2 years ago

fudo729
I have same problem with @xfirebg...
when I type "compiz --replace" in terminal, my window border lost until I cancel the terminal...
Please help me....
 
2 years ago

xfirebg
After activate the compiz i cant switch window borders?  
2 years ago

clem
Nice, thanks Sven.  

Other tutorials from tux-sven

No other tutorials.