Configure Nemo to always use a textual input for the location bar

goinglinux
  7 years ago
  4

By default, the Nemo file browser has the ability to switch between a location bar that displays your location as text, and a path bar that uses buttons instead. Just click the button to the right of the location bar to switch between the two styles of display. 

 
This tutorial describes how to change two check boxes to switch permanently to the textual display -- and how to re-enable the ability to toggle between text and buttons -- from Mint 14 (Nadia) Cinnamon.
 
Configuring the location bar
  1. Start by opening the dconf Editor.
    At the command line (or press alt+F2) type:
     dconf-editor
    or, if you have edited your menu to show the dconf Editor:
    Menu > System Tools > dconf Editor
  2. Next, navigate to Nemo's preference settings using the left pane.
      org > nemo > preferences
  3. In the right pane, ensure that show-location-entry is checked. If it is checked, then Nemo browser windows will show a textual input entry for the location toolbar. If it is unchecked, you will be able to switch between text and buttons on the location bar.

Hide the Nemo's location bar toggle button

  1. Open Nemo
  2. Open the File Management Preference
      From the "Edit" menu, select "Preferences" and select the "Toolbar" tab.
  3. Uncheck "Show toggle button location bar/bar path".

Simply reverse these two settings to restore your ability to switch between the two styles of display. 

If it is checked, then Nemo browser windows will show a textual input entry for the location toolbar.Menu > System Tools > deconf Editor > org > nemo > preferences
 
ensure that show-location-entry is unchecked
 
If it is checked, then Nemo browser windows will show a textual input entry for the location toolbar.
Comments
knowtrash2009 5 years ago

I did the dconf-editor on nemo
org > nemo > preferences

did not see any thing to keep the changed settings after every restart of nemo.
Nemo is a nice product, but this configuration problem is not easy to track down to a solution. so thumbs down on NEMO documentation for now. Every thing else is thumbs up.


goinglinux 7 years ago

Thanks, peppercornmint.

I forgot that I always enable dconf Editor in the menu manually when I install Mint. I have provided some alternate instructions in my edited tutorial. Should work for everyone now.