How to mount a device automatically on start-up using GUI

IDex
  8 years ago
  9

This is simple way to make the system auto mount something without ever toching the cli on Mint 14 + Cinnamon.

Video: http://dl.dropbox.com/u/8496583/Random/MountTuto.mp4

Text(since apparently videos are suspicious):

Go to Disks from the start menu,  select the partition you want to mount, press the "more actions" button, then "edit mount options", uncheck the "automatic mount options" and make sure that "mount at startup" is ticked, press OK and restart the system.

Comments
Busybody 3 months ago

How to auto-mount a partition as your home directory. This took hours of mucking around (because with a fresh install of Linux Mint... where the hell is the comprehensive in-depth user manual? It's not like modern PC's are short of hard drive space, so I'd prefer it on my HD rather than having to scour web pages and still not find the answer.)

Anyway, here's how I did it:
Using the "disks" program under accessories, create the partition size you want. It helps to first create a Linux install disk on a USB stick so you can boot from that, which frees up your internal hard drive so that the "disks" program won't complain that the internal drive you want to work on is "in use".

Once you've created the partition, highlight it and select the "additional partition options" button, which brings up a menu from which you select "edit mount options"

Here you turn off the "user session defaults" button, so that the options below become available for editing.
Make sure "Mount at system startup" is selected. (should be by default)
Make sure "Show in user interface" is not selected.
In the Mount Point text box type "/home/yourusername"
Click OK, and you're done. When you re-boot and display your file system, your home directory will be the contents of that partition.

Your original home directory that was part of the same partition where you installed Linux will now be inaccessible, so before you mount the partition here, you may want to mount it somewhere else first and transfer your original home directory contents to it.

So the way it is on my system now is, when I click on file system, it shows all the directories there, and below it shows the free space on that partition (the one where the OS resides) and in my case it shows 37GB free. Then I select the home directory and it shows that it contains 1 item which has my user name. At this stage it still shows free space as 37GB. But when I click on that directory which has the same name as my username, it shows the contents of my home directory (currently pretty much empty except for the default items like Documents and Videos and Templates, etc) but now the amount of free space shows as 837GB which confirms that the auto-mount worked correctly.


tuganetworks 3 years ago

"File not found"

Please refresh the link


gibbie 4 years ago

'You must uncheck "Show in User Interface"'

8 months after prestonR describes this BUG and it's still there.

Cost me several hours of effort.


markator 5 years ago

It did not work on my machine. Instead, I get an error at startup that sais: Continue to wait, or press S to skip mounting of M for manual recovery


lespinoy 5 years ago

Thx prestonR :-) your solution woks like a charme!!! :-)


prestonR 5 years ago

Menu > All Applications > Startup Applications >
Add (opens little window), put:
udisks --mount /dev/sdx
(where sdx is the name of your disk)
in the 'Command' text box. Name process
something like 'Auto-mount', hit 'Add' and
make sure it's ticked under 'Startup programs'.


windyweather 5 years ago

Problem Solved:
http://ubuntuhandbook.org/index.php/2014/07/mount-partitions-automatically-ubuntu-14-04/

You must uncheck "Show in User Interface". Then it mounts, but you can't see the drive[s] unless you look under the /mnt/yourdrivehere.
sigh...
BUG
- ww


windyweather 5 years ago

Here is a link to a post with images of my situation where the disk will not automount. Thanks,
ww

http://windyweather.net/2014/09/28/linux-mint-17-auto-mount-does-not-work-apparently/


windyweather 5 years ago

I can't get this to work. LM17
I've set the Mount Options to /label= to match the mount point I had when I started to use the disks. I can use Disks to mount the drives manually by clicking the little arrow, but the auto mount option just stops in boot with "Type S to skip or M to something or other". So what has changed that this doesn't work? Or is there some setting? I did a dmesg | tail and there were no relevant messages. Maybe I'll go post some pictures and put a link here to my website so you can see what I see - if that's not "Suspicious". ooooooooo the scary net ooooooooo mhuhahahahahaah

Broken?
Thanks,
ww


MDean 6 years ago

The technique in the video doesn't work on my machine. I have an OCZ PCIe card (appears as two drives), and when I turn Automatic Mount Options "off" and reboot, Mint 17 freaks out. It now shows a boot menu and asks whether I want to mount the drives or muck around on the command line. If I turn the Mount Options back to "on" the system boots properly, although the menu of boot options still appears, but the drives are not mounted. This confuses Crashplan, so it only does a partial backup. Mint should do better at this!


niks 7 years ago

I found this trick myself but it was set to auto by default.
I tried to set manually but it stops system mounting drives
Why I have no idea but will try to find out and post....

Personally I think video works much faster as a teaching tool and you don't need to even understand the language.So well done.

I agree with the risks but this person had to be a member before posting so that already is already one step in the right direction


IDex 8 years ago

@Hammer459
Because making the video was quite effortless(about on par with the text), and was far more explicit IMO.


Hammer459 8 years ago

Why go through the effort of making a video when text is more than sufficient?


remoulder 8 years ago

Users should be extremely cautious about downloading an unknown video masquerading as a tutorial from an unknown user.