RTL8188EUS wireless devices in Linux Mint 13

AlbertP
  6 years ago
  4

This tutorial is not tested on Mint 14 or newer editions!

If you have one of these wireless devices with a RTL8188EUS chip, then this how-to applies to you:

TP-Link TL-WN723N v3
TP-Link TL-WN725N v2
Or any other wireless device that shows up in lsusb as: ID 0bda:8179 Realtek Semiconductor Corp.

This tutorial is not meant for older revisions of said devices, since those do not have a RTL8188EUS chip.

You can download the driver from here: https://github.com/liwei/rpi-rtl8188eu/archive/master.zip
The driver was made for the Raspberry Pi, but also compiles and runs successfully on a Mint 13 system since both use a Linux 3.2 kernel.

Please extract the ZIP file, go to the folder where you extracted it, and right-click inside that folder > Open in Terminal. In that terminal please run these two commands:

make
sudo make install

Then you can reboot your computer, or you can start using the wireless right away with:

sudo modprobe 8188eu

P.S. A new driver version which you can try is at https://github.com/lwfinger/rtl8188eu/archive/master.zip. Please let me know if this driver works too with this how-to, then the driver URL above can be changed, since this is a smaller and cleaner package.

Comments
AlbertP 5 years ago

@ LindseyD: I know I am late answering this, but it is safe. You will however need the folder again if you want to uninstall the driver.


PCNetSpec 6 years ago

for adapters with the following vendor:product ID strings with kernel 3.8

2001:330f
8179:07b8
0bda:0179
0bda:8179

See here:
http://linuxforums.org.uk/index.php?topic=11261.0


peterjram 6 years ago

Slight clarification on how to do this in Mint 15 MATE (see my post below):

You need to enter the extracted folder "rtl8188eu-master" via the terminal after downloading and extracting it from one of the links in the tutorial above. Run those first two commands, restart system, and click on the "connected" icon in the taskbar. Choose which wireless network you want to connect with. Enter your password (from the bottom of your modem, etc.) and click Connect. It should connect in seconds. Hope this helps :)

This worked in Ubuntu 12.04 LTS and Mint 15 MATE. Thanks again!


peterjram 6 years ago

AlbertP,

Thank you for providing the answer to my identical problem! It worked, totally! The only issue I had was having to get to my Downloads folder in the terminal. Once there, if I remember, I ran your commands exactly and watched the show :) Upon restart, I returned to the folder in terminal and ran the last command. It connected by itself. Wow! I tried a whole lot of different ways and attempts before it finally connected. Thanks again.


MagicMint 6 years ago

In consideration of the fact that this seems to be highly experimental, and therefore you need feedback on it, wouldn’t it be better to post it on the forums?