Getting the Huawei modem to work with Linux Mint and NetworkManager

13thSlayer
  10 years ago
  10

And hello there. You probably heard of those Huawei modems - the problem with them is: They identify themselves as two devices. Let's cut it down to buisness: We need to disable one of those "devices". Just run the following in the terminal and you'll be pretty much all set:


echo 'SUBSYSTEM==”usb”, SYSFS{idProduct}==”1001, SYSFS{idVendor}==”12d1″, RUN+=”/usr/bin/usb_modeswitch –vendor 0×12d1 –product 0×1001 –type option-zerocd”'|sudo tee /etc/udev/rules.d/15-huawei-e1550.rules
 


Next just reboot, go to network manager, et viola!

Note: This tutorial assumes you have usb-modeswitch installed. If that's not the case, run "apt install usb-modeswitch" or download packages listed here manually: http://packages.ubuntu.com/search?keywords=usb-modeswitch&searchon=names&suite=all&section=all ( the release name may be found corresponding to the table at http://www.linuxmint.com/oldreleases.php )

Comments
13thSlayer 10 years ago

Remoulder, this worked for mine. I took it from a Russian site and translated, cut out useless bits and posted here.


remoulder 10 years ago

Not all Huawei modems are the same


tux-flo 10 years ago

I use the UMTSMon Manager to get an Internet-connection with a Huwei-USB-Stick, it got lots of useful preferences.