Broadcom 4312 for LMDE

Gramps
  7 years ago
  10

Out of the box the Broadcom 4312 doesn't work on LMDE nor  most of the distros out there. With LM or Ubuntu you can use jockey to install the drivers with Debain it isn't hard it just takes a few more steps. So now we'll see if we can get your Broadcom 4312 wifi working.

I have several laptops with this card in them so what I did was write a script to automate the install. What I am going to so here is post the script with the comments so you can either cut & paste the commands into a script or type them in, your choice. 

# Indicats a Comment

Bold - Commands to type into the terminal if not used in a script

All this will be done in a terminal so let's get started

Menu/Terminal - this will open the terminal window

I have found I have much better luck if I make sure my system is up to date before trying it install the Broadcom driver so lets do that first

sudo apt-get update

sudo apt-get dist-upgrade

 

# ****************** Script Start Here ***************************************

#! /bin/bash
# Install the wifi drivers for Broadcom 4312 wifi
# Add contrib non-free to the app source list befor using - Note this may not
# be necessary on LMDE
############################################################################

## Update the list of available packages. Install the module-assistant and
## wireless-tools packages:

sudo aptitude update
sudo aptitude install module-assistant wireless-tools


## Build and install a broadcom-sta-modules-* package for your system,
## using Module-Assistant:

sudo m-a a-i broadcom-sta

## Rebuild your initial ramdisk, to blacklist modules defined at
## /etc/modprobe.d/broadcom-sta-common.conf within initramfs:

sudo update-initramfs -u -k $(uname -r)

## Unload conflicting modules:

sudo modprobe -r b44 b43 b43legacy ssb

## Load the wl module:

sudo modprobe wl

## Verify your device has an available interface:

 sudo ifconfig

## Configure your wireless interface as appropriate.

##Now so the driver will load when the computer is booted 

sudo gedit /etc/modules

add wl to the end of the file ending with a C/R

## ************ Script ends here ***********************

Now all that is left is to start network manager and configure it for your wireless

Click the Network applet in the lower left hand corner (this assumes that the panel is in it's original position) you should now see you network listed. Click on it and enter you password if needed.

If you connect you can now unplug your ethernet cable.

I don't know if it is really necessary but I normally restart at this point so I can make sure it is all working whiile it is still fresh in my mind as to what I am doing.

This tutorial may become out date as I believe that  Clem and the gang are working on a jockey type program for LMDE but until them I hope this helps to get the BM4312 working

Your milage may vary

*********************************************************************************

Through the years I have had so many issues with this chip set that I will no longer buy a laptop with this chipset. Had one laptop that worked, did an update and it wouldn't work so I reverted back, still wouldn't work. Finally bought an Intel wifi card.



 

Comments
niebling 7 years ago

My broadcom 4312 did not work with kernel 3.0.0-1-amd64 in until I applied the patch for init-MUTEX which works for kernels > 2.6.35 Linux Mint worked up until I upgraded to 3.0.0... this card is not well supported, and needs to be recompiled for new kernels after upgrading to new kernels (and using the patch). Use appropriate Broadcom STA driver hybrid-portsrc_x86-64_v5.100.82.38.tar.gz and the patch available from http://www.mindwerks.net/wp-content/uploads/2011/03/broadcom-sta_4_kernel-2.6.38.patch


pakun 8 years ago

Same Problem in my Dell Vostro 3300, Thanks for this info. Now It's working


ferri 8 years ago

I used this instruction for HP Compaq 6820s with Broadcom 4311 without any problems on LMDE update pack 3, kernel 3.0.0-1.

Thanks


Gramps 8 years ago

Had the same issue with the wife's laptop and had to replace network manager with wicd


siegfried 8 years ago

I did this for kernel 2.6.38 and the module is loaded, network manager can see this device, but it always says, that wireless is disabled even if I try to click the "enable wireless" - it remains unchecked (or it disables wireless faster than I can clickit again)... :-/ It was the same when I tryed to uninstall the sta driver and install the b43 driver. Any ideas?


Gramps 8 years ago

Yes I believe you will need to re-run the script for the new kernal.


billh 8 years ago

Do you have to repeat this with each new kernel upgrade? After doing this (or something like this; I may have found a different site), it worked on my original kernel. Now LMDE has upgraded to a new kernel, and it doesn't work. Does one just repeat the process? (Booting into the old kernel works just fine.)