They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
Brahim
Score: 4
votes: 11
Format: Article

 How to install compiz on Linux Mint 17 Qiana Mate edition


This tutorial applies to the coming release of Linux Mint, Qiana Mate edition which will be out at the end of May 2014 :D

Note:

1- If you have nvidia drivers, install theme before you proceed or else you might run the risk of ending up with a ususable desktop.


2- For unknow reasons to me, you have to delete the default bottom panel then replace it with a new one before you start using compiz, i.e. before you run "compiz --replace, or else you will end up with an unclickabale bottom panel.

3- On Linux Mint 17 RC, you have to upgrade the above packages together with Mintmenu.

4- There is a bug in the Mintmenu and it might look out of place sometimes:


Image



1- install the followig packages:


- compiz
- compizconfig-settings-manager
- compiz-plugins-extra
- libdecoration0-dev

sudo apt-get install compiz compizconfig-settings-manager compiz-plugins-extra libdecoration0-dev



2- In terminal run:


compiz --replace


3- Go to Startup Applications click on add and in the name field write "compiz" and in the command field enter "compiz --replace"(without the punctuation) click on Add again then Close. This is to make compiz start automatically on next logins.

Image

4- To stop that high CPU usage, install dconf Editor:



 
sudo apt-get install dconf-editor


and navigate to org > mate > desktop > session > required-components > windowmanager and replace "marco" with "compiz" or open a terminal and run:



 
sudo gsettings set org.mate.desktop.session.required-components windowmanager compiz




Image


5- Start the Compiz Configuration Settings Manager and check “move window” , "Place Windows" and any other nd any other functions you want to activate

Image

6- Go to General section, check "Gnome Compatibility", open it and go to Commands tab and replace (in all 3 command lines) the word "gnome" with 'mate". Go back and test this: press Prt Sc key. Now you can take a desktop screenshot.

Image

Image


If you want to use Emerald window decorator follow this tutorial by webup8  http://www.webupd8.org/2013/05/how-to-install-emerald-in-ubuntu-1304.html

 

Image

Tags: How to install compiz on Linux Mint 17 Qiana Mate edition
Created: 3 years ago.
Last edited: 3 years ago.
Reviewed: 3 years ago.
Read 0 times.

Comments
3 years ago

naryfa
To fix that "bug", you mention in point 4, you have to disable "place windows" in compiz. That's what displaces the applications menu.

Cheers!
 
3 years ago

Bill_MI
I was considering a fresh install to carefully document what I did. I'm too hooked on compiz/ezoom to not try to give something back but compiz can be sooo much fiddling! I'll see how it goes.

And sorry, I've never used mintmenu. I added it and yeah... it's indecisive where to be, comes up behind things. Is that the issue?
 
3 years ago

Brahim
BTW did you have issues with mintmenu?  
3 years ago

Brahim
Please comment here http://forums.linuxmint.com/viewtopic.php?f=42&t=164935

and if you can rewrite this tutorial please do and we will update this one. Thanks
 
3 years ago

Bill_MI
Got playing with this again and many things are now making making sense.

Selecting the window manager so next startup will run compiz or marco...

gsettings set org.mate.session.required-components windowmanager compiz
gsettings set org.mate.session.required-components windowmanager marco

These commands are handy to switch back and forth or recover with. You do not want to 'sudo' this command as this sets it for root who normally never logs into a desktop.

And the startup app is not needed.

Why the navigation tree in dconf-editor adds an extra level seems to be a schema configuration issue.
 
3 years ago

Bill_MI
Oh... in dconf-editor, it's not that obvious how to change a value. Double-click works. The old gconf-editor was similar.  
3 years ago

Bill_MI
You already include the dconf-editor setting that loads up compiz instead of marco. Navigate the trees to:

org.mate.desktop.session.required-components

...and change windowmanager from marco to compiz. At that point, compiz should be loaded automatically (no start app needed).

While you're there in dconf-editor, notice the Schema displayed for that entry:

org.mate.session.required-components

...so what happened to 'desktop'? Something's strange and I wish I knew what this difference means. I do know one thing, if I run the gsettings command above, I get a 'No such schema' error. But when I remove that 'desktop' level from the gsettings command it appears to work but doesn't stick past reboot as viewed in dconf-editor! So I'm totally confused. :-)

But when set with the dconf-editor it sticks and works on my system with no startup app (shrug).

This is an old Pentium D system with nvidia. Perhaps not all systems will behave like mine but I'm curious if you see something different?

Last, I'd suggest making step 2 (compiz --replace) much later, after some key settings. When run at this time compiz isn't ready. I have absolutely nothing turned on in CCSM.

And yes, I ran into that SAME strange un-clickable bottom panel! Good catch. :-)
 
3 years ago

Brahim
how did you do it with gconf-settings ? I would be glad if you can improve this tutorial!  
3 years ago

Bill_MI
Thanks, my old eyes have e_zoom back! Just a quick addition to this great guide.

There's something screwy with the gconf-editor and gsettings paths involving the 'desktop' level. Compare and you'll see what I mean. I can modify the gsettings path (otherwise I get a No-Schema error) but the changed value won't stick. Yet, if I use gconf-settings all is well AND no Startup app is needed - I'm running fine without one.
 
3 years ago

Brahim
for the Mintmenu go to synaptic package manger and upgrade it to the latest version. I don't think you'll need to do this once the stable release is out, just update your system and you'll be fine but for the time being just upgrade it bro with synaptic as I said.  
3 years ago

Brahim
I forgot to tell you to install "compiz" my bad bro!!  
3 years ago

sebwese
It doesn't work in the RC version of Mint 17: There's some kind of bug with the MintMenu (Non clickable) and the terminal window shows a decor plugin fault (No default theme found).
(Tested with 2 computers and within vmware fusion)
 

Other tutorials from Brahim