They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
Brahim
Score: 9
votes: 19
Format: Article

 How to install Google Earth on Linux Mint 17 64bit properly


As most of us have noticed Google Earth has been increasingly unstable on the lates Linux Mint/ Ubuntu releases, mainly 64bit versions. The most common issue is the application closing unexpectedly shot time after we launch it. Below is the best solution to avoid any hussle.

1- Add 32bit architecture:



 
sudo dpkg --add-architecture i386 && sudo apt-get update


2- Install 32bit libraries:



 
sudo apt-get install ia32-libs


3- install googleearth-package:



 
sudo apt-get install googleearth-package



4- Install google-earth-stable:i386 [b]and not google-earth-stable



 
 sudo apt-get install google-earth-stable:i386




Enjoy the blue planel :D :D

Image


Tags: How to install Google Earth on Linux Mint 17 64bit properly
Created: 3 years ago.
Last edited: 3 years ago.
Reviewed: 3 years ago.
Read 0 times.

Comments
1 year ago

Dobin
Further to my earlier comment: I have moved back to Petra because lots of apps work or work better. I won't bother with a list because I suspect all the experts know the problems.

I have been using Mint to help people with old computers or those who had major problems with the 8 to 10 Windows update. These are retired, low income folk and Mint has been fantastic - well almost. There is this fundamental issue of printer drivers. That needs addressing before Mint becomes a complete alternative to windows. My advice to anyone is, if you have a stable system that meets your requirements DON'T UPDATE.
 
1 year ago

Dobin
Sorry but this just doesn't work.

Google earth work fine on 16 and even 17.1 but not on 17.3.Worked through lots of published fixes but completely solve problem. Gad i kept an earlier version on Mint on the computer.

I am not a computer person so don't ask questions just work out a proper solution. The problem is another one like to long standing MSI mother board issue.
 
1 year ago

kcaldwel
I had GE working fine on 17.1, but on 17.3 I just got the start window briefly. The method above did not fix it.

Per "momist" below, this worked:

"The answer (for me) was to remove GE again, and then go through the whole setup for the 64bit version using the instructions here:
https://bkjaya.wordpress.com/2014/04/27/how-to-solve-blank-panoramio-photo-problem-in-google-earth-on-ubuntu-2/
including the bit supplied by Mr Amirpli. Works OK now."

 
1 year ago

Yash1
Further to my earlier post yesterday,
I now have the problem of multicoloured quilt-type pixellation pattern on the Google Earth screen on the laptop as well. This clears up slowly when at eye-altitude of about 64 km.
I would have expected that the pixellation would clear up once the cache has built up, but this is not happening.
I'll wait for a bit, and will have to revert to 64 bit Google Earth.

Thanks for your help, anyway

Y
 
1 year ago

Yash1
Worked well so far. Thanks.
Only problem is that instead of the green-brown terrain, I am getting a multi-coloured quilt design. The terrain can only be seen when I zoom to say 1000 feet altitude above the place.
It worked wonderfully for my 17.2 instal on the laptop, though.

Thanks

 
1 year ago

olbus409
Thanks for the good advice - I now have a good stable copy of google earth!  
2 years ago

mike2008
Linux Mint 17.2 KDE
If you have done all of the above and it still does not work open your
terminal and enter the following:

cd /opt/google/earth/free/
sudo ./googleearth

Just make sure you have installed "google earth package" and "google earth
stable" from Synaptic. Hope this may be helpful. Also not sure if it is a
security risk running it under Sudo. ;O)
 
2 years ago

momist
OK, so I had Google Earth 64bit working fine in Mint 17, and also in Mint 17.1
Now I'm on Mint 17.2 Google Earth simply closes a second after the globe appears. I've tried several ways of installing it, from the repositories, from GE website and using Synaptic. No joy, it just closes.
I've now installed the 32 bit version, as described here, and it runs - but with bugs. For instance, after zooming to one place, entering a new reference (say place name or postcode,) it doesn't zoom there. The only way to move, other than panning, is to close it and then open a new one.
Also, the Panoramio pictures don't work (again!) and the fix for the 64bit version doesn't do it on the 32 bit version.

The answer (for me) was to remove GE again, and then go through the whole setup for the 64bit version using the instructions here:
https://bkjaya.wordpress.com/2014/04/27/how-to-solve-blank-panoramio-photo-problem-in-google-earth-on-ubuntu-2/
including the bit supplied by Mr Amirpli. Works OK now.
 
2 years ago

jrversteegh
Great! Thanks.  
2 years ago

tux-sven
Jippiii. Now I finally got it working in 17.1! Tank you very much :-)

 
2 years ago

hasuin
This works perfectly well on Rebecca Mate. Thank you!  
2 years ago

pvasshep
I just tried installing GE using these commands but had no better luck than when I installed through Software Manager. Using:
Linux Mint 17 Qiana x86_64
 
2 years ago

cliffyk
Thank you for this--none of the "direct" methods worked for me (Mint 17-Mate w/a 1 GB Radeon 5450 card)  
3 years ago

momist
To anyone trying this and getting references to the CD, there is a setting in your sources file that needs unchecking.
However, I now have a working 64-bit Google Earth with working Panoramio pictures, on Linux Mint 17 (Cinnamon), after following the intructions here: https://bkjaya.wordpress.com/2014/04/27/how-to-solve-blank-panoramio-photo-problem-in-google-earth-on-ubuntu-2/
This will ONLY work on the 64 bit google-earth-stable.
 
3 years ago

Bee1
Very nicely done !  
3 years ago

fd-armingaud
However a problem subsists : HOW do we lanch Google Earth afterwards ? :-o
 
3 years ago

fd-armingaud
For lazy people (like me ;-) ) who do not want to type or selevt text line by line, nor enter their 13-characters password every time, I would suggest this (which is of course functionally the same) :

$ sudo su - # To enter master mode

# Then this script as install-google-earth in /root :

#! /bin/bash
set -x
dpkg --add-architecture i386 && sudo apt-get update
apt-get install ia32-libs
apt-get install googleearth-package
apt-get install google-earth-stable:i386

Enjoy !
 
3 years ago

Hammer459
In the Forums discussion there is now a solution  

Other tutorials from Brahim