They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
Verwijs69
Score: 11
votes: 14
Format: Article

 fix for update-initramfs


I'm running Mint 17 amd64 dutch and i had this warning ..

update-initramfs: Generating /boot/initrd.img-3.0.0-12-generic
Warning: No support for locale: nl_NL.UTF-8

issue:
The problem is that /usr/share/initramfs-tools/hooks/root_locale is expecting to see individual locale directories in /usr/lib/locale, but locale-gen is configured to generate an archive file by default.

i fixed it by running :

sudo locale-gen --purge --no-archive

you will get...

Generating locales...
  en_AG.UTF-8... done
  en_AU.UTF-8... done
  en_BW.UTF-8... done
  en_CA.UTF-8... done
  en_DK.UTF-8... done
  en_GB.UTF-8... done
  en_HK.UTF-8... done
  en_IE.UTF-8... done
  en_IN.UTF-8... done
  en_NG.UTF-8... done
  en_NZ.UTF-8... done
  en_PH.UTF-8... done
  en_SG.UTF-8... done
  en_US.UTF-8... done
  en_ZA.UTF-8... done
  en_ZM.UTF-8... done
  en_ZW.UTF-8... done
  nl_AW.UTF-8... done
  nl_BE.UTF-8... done
  nl_NL.UTF-8... done
Generation complete.


After that run...

update-initramfs -u -t

and warning is fixed... 


Tags: initramfs boot
Created: 4 years ago.
Last edited: 4 years ago.
Reviewed: 4 years ago.


Comments
11 months ago

robinbyron
I don't like seeing warnings on commandline output. This took care of it.

Thank You, Verwijs69
 
1 year ago

Platelet
In last command "update-initramfs -u -t", include sudo, ie: "sudo update-initramfs -u -t". Don't include quotation marks.  
1 year ago

znlambov
Nice one!  
1 year ago

murbahpp
Thank you for your help, it worked.  
1 year ago

chitholian
OK, Works.  
2 years ago

smokin-moe
worked for me, thankyou  
3 years ago

rodoviario
Yes it worked, promoting you... I have watched the error for years now in many machines, now fixing it everywere.

NOTE: sudo update-initramfs -u -t
Because it wont work without sudo
 
4 years ago

jim7fl
Most users will figure this out, but the update-initramfs is a sudo command as well.  
4 years ago

darrell_little
Works great.  
4 years ago

jahid_0903014
nice!
 

Other tutorials from Verwijs69

No other tutorials.