Android Studio 3 on Linux Mint 18.3 Cinnamon

tboxmy
  4 years ago
  -1

Howto install Android Studio on Linux Mint 18.3.

The installed environment

System:    Kernel: 4.10.0-38-generic x86_64 (64 bit)
           Desktop: Cinnamon 3.6.7  Distro: Linux Mint 18.3 Sylvia
CPU:       Dual core Intel Core i3-6100U (-HT-MCP-) speed/max: 499/2300 MHz
Graphics:  Card-1: Intel Sky Lake Integrated Graphics
           Card-2: NVIDIA Device 134f
           Display Server: X.Org 1.18.4 driver: nvidia
           Resolution: 1366x768@59.99hz
           GLX Renderer: GeForce 920MX/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 384.111

 

Open a terminal.

Step 1. Install Java

$ sudo apt install openjdk-8-jdk openjdk-8-doc
$ javac -version
javac 1.8.0_151

 

Step 2. Install Android Studio

Download Android Studio Pack from official site, the link http://developer.android.com/sdk/index.html

$ sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386 lib32z1 libbz2-1.0:i386

$ cd Download
$ unzip android-studio-ide-171.4443003-linux.zip
$ sudo mv android-studio /opt
$ sudo chown -R root.root /opt/android-studio/

 

Step 3. Setup Android Studio for user

$ /opt/android-studio/bin/studio.sh

Android Studio installs the development SDK in the user's home folder.

Follow the instructions to complete installation to user's home folder (in /home//Android/SDK)

My default Android applications target Marshmallow Android 6.0 (API 23). Before creating the first Android Studio Project, choose Settings. Select SDK Platforms -> Android 6.0. Choose Apply ->OK.

Done!

Next step? Create an Android Studio project and install the required libraries.

Comments
Linux4life2211 1 year ago

Unfortunately for me when I got to "Step 3. Setup Android Studio for user" the "$ /opt/android-studio/bin/studio.sh" gave me an error that reads as follows "2020-10-29 12:37:02,050 [ 219] ERROR - llij.ide.plugins.PluginManager - com.intellij.ide.plugins.PluginManagerCore.loadDescriptors()[Lcom/intellij/ide/plugins/IdeaPluginDescriptorImpl;
java.lang.NoSuchMethodError: com.intellij.ide.plugins.PluginManagerCore.loadDescriptors()[Lcom/intellij/ide/plugins/IdeaPluginDescriptorImpl;
at com.a.a.b.b.ar.a(ar.java:121)
at com.a.a.b.b.ar.a(ar.java:71)
at com.intellij.idea.MainImpl.start(MainImpl.java:19)
at com.intellij.idea.StartupUtil.startApp(StartupUtil.java:303)
at com.intellij.idea.StartupUtil.prepareApp(StartupUtil.java:245)
at com.intellij.ide.plugins.MainRunner.lambda$start$0(MainRunner.java:47)
at java.lang.Thread.run(Thread.java:748)
2020-10-29 12:37:02,052 [ 221] ERROR - llij.ide.plugins.PluginManager - Android Studio 4.1 Build #AI-201.8743.12.41.6858069
2020-10-29 12:37:02,052 [ 221] ERROR - llij.ide.plugins.PluginManager - JDK: 1.8.0_242-release; VM: OpenJDK 64-Bit Server VM; Vendor: JetBrains s.r.o
2020-10-29 12:37:02,052 [ 221] ERROR - llij.ide.plugins.PluginManager - OS: Linux

Start Failed: Internal error. Please refer to https://code.google.com/p/android/issues

java.lang.NoSuchMethodError: com.intellij.ide.plugins.PluginManagerCore.loadDescriptors()[Lcom/intellij/ide/plugins/IdeaPluginDescriptorImpl;
at com.a.a.b.b.ar.a(ar.java:121)
at com.a.a.b.b.ar.a(ar.java:71)
at com.intellij.idea.MainImpl.start(MainImpl.java:19)
at com.intellij.idea.StartupUtil.startApp(StartupUtil.java:303)
at com.intellij.idea.StartupUtil.prepareApp(StartupUtil.java:245)
at com.intellij.ide.plugins.MainRunner.lambda$start$0(MainRunner.java:47)
at java.lang.Thread.run(Thread.java:748)

-----
JRE 1.8.0_242-release-1644-b3-6222593 amd64 by JetBrains s.r.o
/opt/android-studio/jre/jre"

Thanks and god bless for any support


sifat6412 1 year ago

$ unzip android-studio-ide-171.4443003-linux.zip

This command doesn't work