LM 19 Auto Mount Secondary Drive (HD Caddy) - HP ProBook

Comptech22
  2 years ago
  -1

ALL:

Racked my head on an issue to do with Auto Mount of a secondary drive for a laptop. I have both a Dell Precision M4600 and an HP ProBook 640 G1.  Both have their CD ROMs removed for additional hard drive caddy.  The Dell is running LM 18.3 MATE and the ProBook LM 19 Beta (16June2018) MATE. 

I use the additional drives as my Dropbox space and additional storage.  All drives are SSDs.  The Dell has always detected the additional drive and has not been an issue from install to use.  Since it is my Primary machine it gets "Stable" Linuxmint versus the ProBook which is my portable testing rig. 

Noticed on LM 19 install on ProBook that the Secondary Drive was not Auto Mounting as it does on my Dell running LM 18.3.  I searched for solutions, 99% centered around fstab, but it did not "feel" right.  I know command-wise we can force it to auto-mount adding a line to fstab, but WHY have I not had such a problem before on the Dell? 

There were some LM Forum answers centered around GUI Disks App.  So I decided to tweak it step by step, Long story short: If you have "User Session Defaults" Selected or Active...deactivate it, while leaving "Mount at system startup" AND "Show in user interface" checked. Click OK and Mount Secondary Drive at that point and exit out of  Disks App and reboot.  

I was able to see the Secondary Drive automatically mounted on the desktop every time I restart the system.  

I'm not a command line ninja or expert in Linux, so I do not know why this behavior has shown up and I'm not going to blame this on it being Beta either.  Just wanted to share my findings.

FYI: Dell and HP ProBook go about BIOS differently.  In the HP BIOS it specifically has a setting to access an additional HD Caddy, and it has to activated in the "boot to" section in order for your drive to be detected.  I also activated the "boot to" CDROM.  The Dell "sees" the drive as long as it thinks there is a CDROM or HD Caddy there automatically.