Pulseaudio - Disable autoswitching to new devices(module-switch-on-connect)

Mash
  2 months ago
  1

Just done upgrade to 18.04 and found Pulseaudio module that may be causing the problem

new in configuration file etc/pulse/default.pa for 18.04:

  ### Use hot-plugged devices like Bluetooth or USB automatically (LP: #1702794)
.ifexists module-switch-on-connect.so
load-module module-switch-on-connect
.endif

Disable this module to stop usb device grabbing default when plugged in

sudo nano etc/pulse/default.pa

and comment out load-module command

 ### Use hot-plugged devices like Bluetooth or USB automatically (LP: #1702794)
#.ifexists module-switch-on-connect.so
#load-module module-switch-on-connect
#.endif

Better option is copy etc/pulse/default.pa to home folder

cp /etc/pulse/default.pa ~/.config/pulse/default.pa

Pulseaudio user configuration in home overrides default configuration.
don’t need sudo to make changes.
If changes cause problems can delete home folder configuration and revert back to default easily