They offer different flash templates with latest features.

Forgot password
Written by:
Score: 24
votes: 32
Format: Article

 Installing driver for Broadcom 802.11b/g wireless cards

This tutorial is applicable to LinuxMint Debian Edition for it doesn't come with the Hardware Driver option (System->Administration->Hardware Drivers) found in Ubuntu and LinuxMint. Installing LMDE will not automatically install the driver for you so you have to manually do it from the Terminal.

Steps are outlined below:

You are required to connect to the Internet with the LAN interface before proceeding.

1.) After successfully installing LMDE, you have to update it first prior to installing the driver.

sudo apt-get update && sudo apt-get upgrade

2.) After a successfull update, we can now install the desired driver for our Broadcom wireless card:

sudo apt-get install b43-fwcutter firmware-b43-installer

All you have to do is wait for the installation to finish and you will be able to use the Broadcom wifi card.


[March 19, 2011]

Here's an update if you're trying to install the driver on a netbook with low-power b43 chipset:

sudo apt-get install b43-fwcutter firmware-b43-lpphy-installer


[April 26, 2011]

Updating my LMDE with the latest kernel had my broadcom wireless messed up. In order to have my connection back, I had to use a different set of commands.

sudo -i
apt-get install module-assistant wireless-tools broadcom-sta-common broadcom-sta-source
m-a a-i broadcom-sta
echo "blacklist brcm80211" >>/etc/modprobe.d/broadcom-sta-common.conf
update-initramfs -u -k $(uname -r)
modprobe -r b44 b43 b43legacy ssb brcm80211
modprobe wl

Now, it's working fine. You had to issue this command whenever you have to upgrade your current kernel.

Tags: broadcom driver, wireless
Created: 5 years ago.
Last edited: 5 years ago.
Reviewed: 5 years ago.
Read 2219 times.

1 year ago

I did steps 1-2 and it worked fine after reboot. The hardware is HP Pavillion dv6000 PN:dv6243cl  
1 year ago

Thank you for writing the only solution that works for the Broadcom driver issue. It's surprising how many "solutions" you find for getting your Broadcom b4311 to work with Mint when you Google it, however this is the only one that actually works. All the other ones simply give you typing practice and excercise your patience. Wouldn't it be grand if Mint would finally fix this issue? You would think by now (17.1) that when you go to Administration - Driver Manager - and see the the device listed and enable it, that would do it. Alas, like all the other supposed "fixes", it does absolutely nothing.
Thank you again. I have to go through this every time I upgrade Mint.
Dell D630
Broadcom b4311
8gb RAM
Mint 17.1 64bit Cinnamon
2 years ago

There seems to be a problem with bluetooth and Wlan on the same device, but this brought an old HP Compaq NX6325 onto WiFi - finally. Excellent tutorial!  
3 years ago

Excellent guide :-)

I call out to the 2-3 people out there who are like me and are still using the old Dell Inspiron 6400 with the Broadcom B43 wireless card:


I used the "Additional Drivers" update and it ended badly. I have never seen anything like it before in any Linux distro cause it killed my entire OS. Initially it killed the X server (recovered) and then the wired connection didn't work (rebooted). Every now and then it reported a crash or crashed the X server or the entire system without warning. No dpkg or roll back helped.
Seen it on Mint 13,14,15 so I guess it is not version dependent. After using the above guide, my Mint 13 runs smoothly without any problems for weeks now.

Be advised, use the above guide instead of the "Additional Drivers" update and have fun with Mint. It is an excellent OS.
3 years ago

My laptop is HP CQ41, and I have problem since my wireless switch is Hard blocked and not using Fn key. This tutorial really usefull, thanks.  
3 years ago

Thx ianace! Made my old ACER ASPIRE 5020 wifi work.  
4 years ago

Works on ACER ASPIRE 5755G a few errors during installation but finally works.. now i'm connected with my wifi adapter...

Thx a lot.. i thinking about changue to Ubuntu or other distro because this bug..

Thx a lot again!
4 years ago

Thanks this really helped me out.  
4 years ago

Worked like a charm! Tnx very much for the help!!!  
5 years ago

Thank you! I didn't want to install the recommended STA drivers (BTW I own a Lenovo S10e Netbook) and the low power b43 worked like a charm. My laptop even gets a stronger and more stable signal everywhere. Again, thank you!  
5 years ago

Good tutorial.  
5 years ago

this may take an error:  
5 years ago

Thanks for this solution. I had been reading the forum threads and was getting no where.I installed Mint "Julia" on a HP Pavillion DV4 1225dx and it needed the low-power b4 chipset and it works fine now.  

Other tutorials from ianace