Fix for ACPI=OFF Boot Option for Toshiba E205-S1904 (may apply to others)

  9 years ago

When you have tried to boot any linux distribution, have you had the issue that you cannot get past: "Kernel_Thread_Helper (and some numbers...)? 


If so, then I have the fix for you. If you have not already installed Linux, when you get to the boot screen that gives you an option for Normal boot or Recovery Boot, choose the option to edit the boot options, (this is sometimes done by hitting "e" or "tab"buttons, just depends on your distro)

then on the line that says:  GRUB_CMDLINE_LINUD_DEFAULT="quiet splash"

change it to say: GRUB_CMDLINE_LINUD_DEFAULT="quiet splash acpi=off"
EDIT: don't use "acpi=off" it will disable your cooling system... not allowing your fan to cool your CPU. 

this will get you through to be able to install, however this can hurt your system if you boot with this option everytime because it turns off the fan, and all of the thermal power controls. 


Once installed, you need to open up a terminal, and type: "Sudo nano /etc/default/grub" (without the quotes)

then when you get the boot options, go to the line: GRUB_CMDLINE_LINUD_DEFAULT="quiet splash"

and make it look like this: GRUB_CMDLINE_LINUD_DEFAULT="quiet splash acpi=enable pci=noacpi pci=assign-busse acpi=ht"
EDIT: try without "pci=noacpi" because it would contradict "acpi=enable" ... 

Then hit CONTROL + x, enter, enter


once you have exited the editing portion, you then need to update the GRUB file, 


type "sudo update-grub" and this should update everything. you should be able to boot without any issues now. :)

<meta content="text/html; charset=utf-8" http-equiv="content-type" /> <meta content="text/html; charset=utf-8" http-equiv="content-type" />
technophant 7 years ago

I noticed some typos that will affect the results. It's "pci=assign-busses" not "pci=assign-busse" and also "Sudo" while capitalized will return "command not found".

"pci=assign-busses" will tell the kernel to always assign all PCI bus numbers, overriding whatever the firmware may have done and "acpi=ht" disables all of ACPI except Hyper Threading. There's other modes of disabling in the link below.

Also, if you are not sure if you have a ACPI thermal/fan control there's instuctions on how to find out. I have a Tosh A660 and I have neither "fan" or "thermal_zone" in /proc/acpi/

Debugging ACPI:

mchype 9 years ago

@mark_t this was meant for the Toshiba A205-S1904 Model Laptop... Which was why I tagged Toshiba Laptop and not say, Acer....

Sorry that it didn't work for ya.

kostanakis 9 years ago

thanks, you just saved me)

mark_t 9 years ago

Not working for ACER ASPIRE 4752G

mchype 10 years ago

While I know that it may not work for all computers experiencing this issue, the main thing was it was supposed to be directed at Toshiba Laptop users... I had thought that I had added that in. Obviously not. And While the ACPI=OFF option DOES work... It did not give me as much control as the options that I added did. The ones that I added worked best for my machine, and it seems that the only thing that I couldnt do was to adjust the screen brightness. However, I have since stopped dual booting the machine.

Schlafmuetze666 10 years ago

Maybe doesn't work on all systems, but still the best solution I've found yet. Fixed problem on eeePC, some Packard Bell Netbook and on my Core2Quad Desktop.

Just saying "ACPI=OFF" helps too, but then the multimedia/special keys won't work.

remoulder 10 years ago

Turning off acpi may help some, but your post cannot be generally applied as kernel options are specific to the hardware being used, what works for you may not for someone else.