They offer different flash templates with latest features.

Forgot password
Written by:
Score: 1
votes: 11
Format: Article

 broadcom BCM4311 nightmare solved (linux mint 11)

After spending a hell of alot of time following many, many guides online, trying to get my wireless working I have finally found a solution. This worked for the Broadcom BCM4311 wireless card on a dell inspiron 152 Being fairly new to Linux I will try and keep this as simple as possible (simple enough for a noob like me to understand).

The following worked on linux mint 11 which is based on Ubuntu 11.04, I have not tried this on Ubuntu but would imagine it would work the same (sorry if it does not, I'm no expert).

Firstly Ignore the desktop notification offering to install propriatry drivers, from experience these won't work and just get in the way. Connect to the internet using the wired connection and download the following:


If this link does not work, check the post below or contact me and I will email you the file.

Save it somewhere you remember, I used /home/jamie/Templates as this is an empty folder I don't use (jamie is my username, replace this with your own).

Locate the file, right click on the icon and click "extract here"

next open a terminal (learn how to use this, might not be pretty but is very useful and common tasks are very simple, check out some guides online)

copy and paste the following, (ctrl & V will not paste to a terminal you must right click and press paste)



tar xjf b43-fwcutter-011.tar.bz2
cd b43-fwcutter-011
cd ..



once this has finished copy and paste this (note the opening line is the location of the file we extracted earlier, instead of "home/jamie/Templates" enter the location you chose)



export /home/jamie/Templates=”/lib/firmware”
tar xjf broadcom-wl-
cd broadcom-wl-
sudo ../../b43-fwcutter-011/b43-fwcutter -w /lib/firmware wl_apsta.o



Now click the connections icon in the bottom left of the screen and you should have a nice list of wireless connections to choose from.

If it worked save this guide on a memory stick or something, It took me an hour to find the same solution after a re-installation!
If this did not work for you I'm really sorry. I had to try around 10 different guides before I found one that worked. Aside from this linux mint is brilliant, having started with ubuntu im finding mint alot nicer to use and more stable too.
Thank you to Acid_1 (via angelbeast) who wrote the guide below on which I based this post.
Good on you for ditching microsoft, Its been 3 weeks for me and already I know I'll never go back.
enjoy linux ;)

Tags: broadcom, bcm4311, wireless, mint, mint 11, chipset, wireless card, wifi, dell, inspiron 1520
Created: 6 years ago.
Last edited: 6 years ago.
Reviewed: 6 years ago.
Read 0 times.

6 years ago

Apologies about the text, I spent alot of time editing the post but could not get rid of the http. as for the link, the original link is dead, I will post my copy of the file online and get it fixed. This guide is supposed to work for several of the broadcom BCM chip's however I can only verify the one I have. thanks for the feedback  
6 years ago

Re: BCM Wireless Problem

Postby Can0dope on Wed Sep 07, 2011 11:31 pm
I had the exact same problem... But being a complete noob, I was just trying to find anything, so I installed all of the Broadcom drivers. BAD IDEA. :roll: That just made it so neither of my network adapters were even recognized by the system. So I went online on my phone and did a little research. Complete format, fresh install, hooked up via EasyTether, then open Software Manager and search "firmware" and found the "firmware-b43-installer". Installed, then rebooted. Works perfect now! :mrgreen:
6 years ago

The tutorial is informative however the format needed testing. Very confusing as to the text what is information and what is http language.

No link to the file to be downloaded.

Is this only for the BCM4311 or does it relate to others?
6 years ago

sorry there seems to be some coding amongst the post, despite alot of fiddling about I cant get rid of it......noob!  

Other tutorials from jamiebakeruk

No other tutorials.