How to install Broadcom b43 wireless driver without internet / offline

prosiedem
  7 years ago
  8

Ok, that's the theory:

1. From another computer download b43 firmware into flash disk and put it on your Desktop:

http://downloads.openwrt.org/sources/broadcom-wl-4.80.53.0.tar.bz2

2. Open terminal and write:

cd '/home/`uname -r` ~/Desktop/broadcom-wl-4.80.53.0 2/kmod'

then:

sudo b43-fwcutter -w /lib/firmware/`uname -r` ~/Desktop/wl_apsta.o

Wait until extracted, then:

sudo modprobe b43

and Voila!  you've just got your wireless working.

Just let me know if there is no errors, as got no chance to test it myself yet.

 

Comments
Jwtrahan 4 years ago

Good call sloshnmosh. I had no way to hard line to the Internet. You saved me.


sloshnmosh 4 years ago

in Linux Mint 17 to install broadcom drivers OFFLINE simply: reinsert the install disk and browse to /pool/main/e/eglibc and click on: libc-dev-bin_2.19-0ubuntu6.3_amd64.deb and after that installs click on: libc6-dev_2.19-0ubuntu6.3_amd64.deb after that installs browse the disk to:/main/b/bcmwl and install bcmwl-kernel-source_6.30.223.141+bdcom-0ubuntu2_amd64.deb you should now have wifi. This bit of foolishness is probably due to copyright b/s.


prosiedem 5 years ago

@skolsuper and @tat2carson, you can go to /kmod folder. RMB and choose 'Open in Terminal'. Then run:

sudo b43-fwcutter -w /lib/firmware/`uname -r` ./wl_apsta.o

When extracted, run:

sudo modprobe b43


prosiedem 5 years ago

#collinthegeek, the command should be run inside the catalog broadcom-wl-4.80.53.0 2/kmod. Go to the catalog, right clic and choose 'open in the rerminal' option. That should do the trick.


collinthegeek 5 years ago

After I run the "Sudo modprobe b43" command I get no output at all. I let it run for about ten minutes and then stopped it.


prosiedem 7 years ago


prosiedem
@rayratliff you can replace the `uname -r` simply with your username.

@luxgeek it might happened that that particular command did not worked for you because:

a) you might download newer version of drivers with different number;
b) the name of you catalog might be different;
c) I simply messed up the `uname -r` which you might be right;
d) you might need to remove '2' from command cd '/home/`uname -r` ~/Desktop/broadcom-wl-4.80.53.0 2/kmod' The one just before /kmod

Frankly, I don't know and I don't think that should make difference to you too. The thing is you need to copy drivers catalog somewhere (e.g. Desktop), unpack and go to folder kmod. Then you can either execute cd command from Terminal or right click somewhere opened window of kmod cataloge and from menu choose Open in Terminal option. And then run

sudo b43-fwcutter -w /lib/firmware/`uname -r` ./wl_apsta.o

When extracted, run:

sudo modprobe b43

It's hard for me to check this out as in newer version all drivers and firmware works fine. Hope that help, if not- let me know.


rayratliff 7 years ago

After entering above into Terminal nothing happened. No errors from the terminal. The grave accent(left facing single apostrophe) I do not have on my keyboard but found it on the character map.
I have a new install of Linux Mint 12 from a USB drive on an Acer Aspire One. I still get "firmware missing". nothing happened.
After typing each line should I hit enter? Are there some steps I should do B4 doing the above?
Thanks,
Ray


luxgeek 7 years ago

Should we be creating /home/`uname -r` first?


luxgeek 7 years ago

This didn't work for me (still trying to find a solution) when I tried this: cd '/home/`uname -r` ~/Desktop/broadcom-wl-4.80.53.0 2/kmod' I got "directory not found" which makes sense since there's no "/home/3.0.0-12-generic" directory.

Any additional info would be great :)


prosiedem 7 years ago

Another thing I came across might be using slimmed CD version rather DVD which contain full a-v codecs and shell commands I think. Correct me if I'm wrong.


prosiedem 7 years ago

I assume you've download broadcom-wl and moveed to kmod catalog before running the command?


xaion1 7 years ago

Good evening, I've tried this and the terminal states 'sudo: b43-fwcutter: command not found' after entering 'sudo b43-fwcutter -w /lib/firmware/`uname -r` ~/Desktop/wl_apsta.o'. I am using Lisa now. Thanks.