RAT7 mouse install

faheyd
  7 years ago
  5

Got this off the web:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/615892


cd /etc/X11/xorg.conf.d/
#if folder doesn't exist, create it
sudo mkdir /etc/X11/xorg.conf.d

cd  /etc/X11/xorg.conf.d

 

#then do the following

 

sudo vi 910-rat.conf

#the above will create file 910-rat.conf and it will not get overwritten as if you put it in xorg.conf

# add the following to the file, use 'i' in vi to insert, esc to get out of insert mode

Section "InputClass"
        Identifier "R.A.T."
        MatchProduct "R.A.T.7|R.A.T.9"
        MatchDevicePath "/dev/input/event*"
        Option "Buttons" "17"
        Option "ButtonMapping" "1 2 3 4 5 0 0 8 9 7 6 12 0 0 0 16 17"
   Option "AutoReleaseButtons" "13 14 15"
        Option "ZAxisMapping" "4 5 6 7"
EndSection

# esc, then wq!
# reboot
sudo reboot now

 

Horizontal also works

 

 

 

 

 

 

 

 

Comments
faheyd 6 years ago

Well, if you're on LM14, and you restart kdm and it brings you to a terminal prompt, just 'startx' will get you back to X11.


faheyd 7 years ago

OK, rather than reboot, try this in command line in terminal (CLI)
sudo /etc/init.d/kdm restart
or
sudo /etc/init.d/gdm restart

that should restart your X server and all is good hopefully after that.
Test with documents and web browser to check all your mouse settings.


faheyd 7 years ago

There is probably an easier way to implement the change instead of 'reboot now', and just restart the x-server. If you know the painless way to do that (xserver restart), please post here and we'll add it.