Receive files from a Bluetooth device in Linux Mint

Thinker
  6 years ago
  12

By default receiving a file from a bluetooth device is not possible in Linux Mint 12. To enable file receiving, install obexftp and Blueman. Then click on bluetooth applet on Gnome Top Panel and make sure that “Device visibility” is on. Files can now be received which will be located at /home/user_name/Public folder which can be changed later on from blueman preferences.

If problem still persists, right click on Blueman applet (normally located at notification area) and choose “Local services”. Under "Transfer" tab, make sure “File Receiving (Object Push)” is enabled.

 

To change default location for received files:

Right click on Blueman applet and choose “Local services”. Under "Transfer tab", give the new location by browsing to a new path in front of “Shared folder”.

 

To enable receiving files automatically without confirmation message everytime:

Double click on Blueman applet (in Gnome-Shell, it is located on bottom transparent notifications panel), right click on device name from which multiple files have to be received, select Trust. Next time, bluetooth will not ask any confirmation message and files will be received automatically. But make sure that receiving files from trusted devices is enabled. To check whether it is enabled or not, right click on Blueman applet, choose “Local services” and verify it under "Transfer" tab.

In Mint 13 or Gnome Shell 3.4, double clicking on Blueman applet doesn't work. So instead of double clicking, right click on applet and select "Devices". Then perform the above steps to receive files automatically.

Comments
dsiddens 4 years ago

Using a Casio C771 and LM17, 64, Cinnamon I can get a pairing to show on both devices but can't make connection.


dragondave59 5 years ago

Blueman is broken in Linux Mint 17 (Qiana). It will find devices but fails to connect. At least with the old bluetooth manager I could get it to connect properly to my Android phone & my KS Manhattan headphones.