They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
piday
Score: 3
votes: 6
Format: Article

 UEFI Install dual-boot


<style type="text/css"> <!--{cke_protected}{C}<!--{cke_protected}{C}<!--{cke_protected}{C}<!--{cke_protected}{C}<!--{cke_protected}{C}<!-- @page { margin: 0.79in } P { margin-bottom: 0.08in } -->-->-->-->-->--> </style>

 

 

EDIT: This Tutorial seems to be a bit out of date. It was an ugly way I found to get the dual boot working (ie switching between OS in bios as supposed to Grub). However, the comments are very useful so I will leave this up for reference.

 

 

I had quite a bit of trouble trying to dual boot my laptop (Asus N56VM) in UEFI with GPT partitioning. I read quite a bit on it and this is what finally worked for me.

I booted from a live USB in UEFI. (The live cd kept booting in bios.)

First I made these partitions in gparted.

 

/efi/boot     (FAT 32)

/boot     (ext4) (not 100% sure if this is needed, but I have it and there is no issues)

/     (ext4)

swap     (swap) (Not necessarily needed)

/home         (ext4)

(Note: for boot, root, and home you can most likely choose something other than ext4)

 

The install is mostly the same as normally just with adding the EFI boot

So start the install. Choose manual install (Specify partitions manually). Click on the FAT32 partition and set the mount point to “EFI boot” (or EFI something). The rest is the same as if you were doing a normal dual boot.

Now the one down side of this is that you can only switch between OS in the Boot Manager when the computer first starts (there is an option that says linuxmint). I haven't yet figured out how to get grub to boot windows but at least I can boot either OS from boot manager.

Please let me know if this works for you. If this is confusing, I said something incorrect or if you have an improvement PM or leave a comment and Ill try to better explain and/or fix it.

Thanks,

PiDay


Tags: EFI, UEFI, GPT, dual, boot
Created: 1 year ago.
Last edited: 11 months ago.
Reviewed: 1 year ago.
Read 0 times.

Comments
11 months ago

hitechkarthik
Hi all,

I followed this Simple method to solve the Dual boot problem of linux mint with Windows 7 is in my machine and it worked fine for me.

Hope this will help others for dual boot. Follow the below steps

1.Set some free unallocated disk space from your windows machine

2.Downgrade your BIOS to lower version dated on or before May'12 (for Asus N56VM laptop downgrade the bios to BIOS 206(version)---follow the below link for more details "http://forums.legitreviews.com/about41080.html")

3.After downgrade and first restart, set the BIOS UEFI to "disable" mode or "Legacy" mode. Save the BIOS and restart the machine.

4. Press "Esc button" during restart to select the bootable linux mint USB...
Now you can follows the normal installation procedure as in below tutorial
"http://www.avoiderrors.net/dual-boot-linux-mint-14-nadia-with-windows-7/"

5.Once after the linux mint installation follow below tutorial to fix/create boot menu for OS selection(Win 7 or linux mint)
"http://linuxpoison.blogspot.de/2012/02/tool-to-repair-frequent-boot-problems.html"

regards
karthik
 
1 year ago

Daviddd
The following worked for me !!
Lenove ThinkCentre Edge72
Run Mint live CD, use GPARTED to create new partition table --> "MS DOS"
Make following changes in BIOS:
startup - boot mode --> legacy only (I think legacy means not EFI)
startup - boot priority --> legacy first
security - secure boot --> disabled
Then I installed Win7 from the DVD (which did not convert the partition table) at the start of the disc, created a data partition leaving a space for Mint 13 Maya at the end, and installed Mint.
The first start of Windows 7 gave an error but it clicked past and started.
Now it works fine with selection of the operating systems in Grub.
The main difference is that compared to Mint, Win7 seems horribly slow and brings incessant annoying pop-ups.
 
1 year ago

Knacki
Hi, can you let me know how you managed to boot on a live usb? I can't find the settings in the boot menu to specify usb.
Thanks
 
1 year ago

fromderpool
I've just bought a new ASUS N56VM and have been trying to set it up to dual boot Windows 7 and Linux Mint 13 Maya. I followed this tutorial and although the install of Linux Mint appeared to proceed OK the computer just proceeded to boot into Windows 7 when started. However, I have managed to get a dual boot working using Grub 2 as the boot loader and with a Windows 7 boot loader as entry on its boot menu.

First I managed to get the computer to boot from the Linux Mint 64bit DVD by changing the boot order in the boot section of the UEFI BIOS after pressing F2 during startup. Although this is labeled as boot order it appears that it only attempts to boot from whatever is at the top of the list and fails if no CD is present so in order to boot from the hard disk again you have to change the order back to put the hard disk first.

I found a very useful document on the Ubuntu community site at http://help.ubuntu.com/UEFI (capital letters required). Although this is written for Ubuntu it works for Linux Mint as well. This proposes the use of a utility called Boot Repair to be found on the Live CD/DVD of Ubuntu-Secure-Remix 64bits of Ubuntu 12.04.1. Its worth reading the complete document but I fixed the dual boot problem by following the section on Converting Ubuntu to EFI mode near the end.

Running Boot Repair goes though several steps and requests that you manually enter some of these steps in a terminal yourself. At completion, however, when I changed the boot order option back to the hard disk and booted the system a GRUB 2 boot menu appeared with both Linux Mint and Windows 7 present and both boot successfully when selected. Whatever it does it fixes the failure to install the boot correctly for UEFI systems that is present in Ubuntu 12.04 and has been carried forward into Linux Mint 13.

I hope this comment proves to be useful to the Tutorial writer and anyone else struggling to dual boot a computer with UEFI using Linux Mint 13.
 
1 year ago

piday
The usb had two separate options to boot, the normal one and then one that started with UEFI: . I initially tried installing from a cd and installation seemed to be successful until I restarted mint wouldn't start. After a lot of searching I found many places stating this the reason. On a side note the only way I could access the cd installation was to boot from a cd and select "boot from local drive"  
1 year ago

avasili
Hi

How did you find that the cd boots in bios and the usb in UEFI?
 
1 year ago

piday
@iampcman it is the new replacement of bios http://en.wikipedia.org/wiki/UEFI. There is also been some controversy in the linux community about the soon to be UEFI and secure boot. But this tutorial only covers UEFI booting with GPT partitioning.  
1 year ago

iampcman
What is UEFI?  

Other tutorials from piday

No other tutorials.