They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
PiGeek
Score: 8
votes: 15
Format: Article

 Connecting to android 4.x+ Devices with MTP


These instructions are outdated, native MTP support is built into Mint 15 and above, if it does not work, please ask for help on the forums(http://forums.linuxmint.com/)

To do so you need a program called Go-mtpfs. You can compile it yourself, but for ease of use you can install it with these commands(remove the quotes).

 

"sudo add-apt-repository ppa:webupd8team/unstable"

"sudo apt-get update"

"sudo apt-get install go-mtpfs"

 

After installing Go-mtpfs you need to plug-in your android device with a usb cable and run this command to mount it.

 

"go-mtpfs /media/MyAndroid"

 

Now just browse to it like a usb drive.

When you are finished run this to unmount it.

 

"fusermount -u /media/MyAndroid"

 

I suggest creating scripts for easy mounting and unmounting.

It worked with my Nexus 7 and I have heard that this has high compatibility, but I cannot test it further.

 

Update: it appears that mtp will be natively supported in 13.04 and can be backported with instructions here(http://www.webupd8.org/2013/01/upgrade-to-gvfs-with-mtp-support-in.html) however it may not work.

Also use at your own risk as i think it messed up my nadia install


Tags: MTP , Android
Created: 1 year ago.
Last edited: 7 months ago.
Reviewed: 1 year ago.
Read 0 times.

Comments
5 months ago

twolf
It works perfectly with:
Samsung Duos GT-7392 with Android 4.1
Mint 13 XFCE 3.2.0-58-generic x86_64

Thanks a lot
 
6 months ago

ess67
Well, My GS3 was working with 4.1.2, but I just upgraded to 4.3 and now the gigolo/gvfs-bin combo no longer works... I guess I'll post to the main column.  
7 months ago

ess67
I was having this problem with Mint 16 KDE and I installed gigolo and gvfs-bin from the Software Manager. Once I did this and restarted Dolphin, it worked fine. My phone is Samsung GS3 running 4.1.2 using MTP.  
7 months ago

ohemetophobia
Maybe someone can help. I'm on Linux Mint 14 and I've got this working, thus far. My issue is that I have a Nexus 7 (grouper) that can only boot into recovery (CWM 6.0.4.3). So, when I use the path for /media/MyAndroid it doesn't find anything. I need to know what I should put in there to make it recognize my tablet so I can sideload a ROM to get it operational again. Help, please!  
7 months ago

Barti7
Hi!

I've tried it with my Nexus 7 (first edition) but it does not work. I'm a total noob (until now ive always used windows) so I don't know what I am doing wrong. Maybe it has to do with the update to android kitkat? If not, then maybe the commands in this post not up to date anymore? Please help, because I backed my music up on the tablet, but now I can't transfer it back.. Tnx in advance!!
 
7 months ago

PiGeek
@ericramos1990 As I noted above, there is native support for most MTP implementations build into mint 15 and above.

If you are still having trouble with it I suggest you open a thread on the forums so that more knowledgeable people can help you debug it.
 
8 months ago

ericramos1990
Hi! Was it removed? O.o

I upgraded to petra yesterday, I tried installing go-mtpfs, but I got:

E: Unable to locate package go-mtpfs

=(

Anywhere else I can find it, I grew to be dependent on it! =D
 
8 months ago

jimbob87
I always get the following output and doesnt work:

HTC One X on 4.1, Linux Mint 15 Cinnamon 1.8.8


PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
 
9 months ago

billybilboa
Working perfect with HTC One X+ on 4.2.2 android on Linux Mint 13, thank you!!  
10 months ago

_berserk_
Works like a Charm on Mint 15 XFCE with Samsung S3. Thank you for this. Only issues I have had are transferring Flac files.. it generated a strange cannot delete something error.. however it did successfully copy them over.
:D
 
1 year ago

Teutates
followed it all and seemed to be going well but when I tried to mount my HTC One X mobile as a drive I got the following response:
"
mark@Athelstan ~ $ go-mtpfs /media/MyAndroid
2013/07/20 22:50:13 compiled against libmtp 1.1.5
Device 0 (VID=0bb4 and PID=0fb4) is UNKNOWN.
Please report this VID/PID and the device model to the libmtp development team
2013/07/20 22:50:13 found device unknown: unknown (0bb4:0fb4) @ bus 1, dev 23
:
ignoring libusb_claim_interface() = -6PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
LIBMTP PANIC: failed to open session on second attempt
2013/07/20 22:50:14 rdev.open failed: open: open returned nil
"
Can anyone offer any advice as to how I can resolve this issue please?
 
1 year ago

Klausb89
Works great with my LG Optimus G E975 and Linux Mint 14.

So thank you!
 
1 year ago

aviggiano
It works! Linux Mint 14 + Samsung Galaxy S3. By the way, it needs reboot.

Thanks for the answer.
 
1 year ago

grimdestripador
I would expound more about what you are doing...  
1 year ago

Lunatico
Nice one! Works with Nexus10 on LM 14. I just wish it would be a plug-and-play thing.  
1 year ago

Wogabun
not working with Samsung Ace  
1 year ago

iulianh
Works with Galaxy Tab 2 7.0! Thanks!  
1 year ago

Rusty_1
Running Mint and successfully mounted my Galaxy S3. Thank you so much  
1 year ago

larmi
official gvfs MTP Backend
ppa:langdalepl/gvfs-mtp
and webup8
ppa:webupd8team/gvfs-libmtp

just install updates from one these ppa's and reboot
after reboot everything should be automatic.
tested with lg l5 and first time took some time and contains some bugs not perfect always.
 
1 year ago

softsquirrel
I do a reinstallation, not it works!!!
So we need only a support, that Linux Mint work by itself...
cheers
 
1 year ago

softsquirrel
Hi thank you,
works great I mean the installtion, but then I get this error:

$ go-mtpfs /media/MyAndroid
Error: Unable to open ~/.mtpz-data for reading.
2013/01/19 12:15:20 compiled against libmtp 1.1.5
Device 0 (VID=18d1 and PID=4ee1) is UNKNOWN.
Please report this VID/PID and the device model to the libmtp development team
2013/01/19 12:15:20 found device unknown: unknown (18d1:4ee1) @ bus 2, dev 4
:
Android device detected, assigning default bug flags
2013/01/19 12:15:20 storage ID 65537: Interner Speicher
2013/01/19 12:15:20 backing data /tmp/go-mtpfs836280287
/bin/fusermount: failed to access mountpoint /media/MyAndroid: No such file or directory
2013/01/19 12:15:20 mount failed: fusermount exited with code 256

Will be great when we have a scribt, wich mounts and umount automaticly ore have it under devices in nautilus....
but first I must work, that the filesystem is mountet.
cheers
 
1 year ago

Big_Al
Yes this worked for the LG otimus 7!  
1 year ago

Big_Al
Life Saver!!

Just got a Samsung Galaxy S3 i9300t and discovered I couldn't connect via USB like my old Samsung Galacy Ace.

This works a treat!

I'll try it on my sons LG Optimus 7 phone shortly as that's on Android 4 also.

I'll post a comment when I test it.

Cheers.
 

Other tutorials from PiGeek

No other tutorials.