How to have bluetooth turned off (not disabled) at start-up in Mint

AshBaby
  4 years ago
  2

Hi folks,

 

Ever had trouble because everytime you turn on your lappie, the bluetooth is on by default? You get annoying pings, or worse, if you dont, you forget n run out of battery faster.

Here's a quick way to ensure bluetooth is off by default when the laptop turns on..

Go to terminal --> Ctrl+Alt+T

type:

sudo su 

sudo gedit /etc/bluetooth/main.conf

Look for an entry called 'Initially powered = true' and replace true with false.

Turn off the laptop. When you turn it on, bluetooth would be OFF

Added - 6th Nov 2012 - Please remember, if you add level 3, 4 or 5 updates, you might have to do these steps again. Also, a restart bypasses this file so will have the bluetooth on if a restart is done.

Comments
camypaj 1 year ago

I guess this is old now, and does not work anymore, but in short:
1) you don't need "sudo su" if you prepend the next command with sudo, so second command is enough
2) these days, using "sudo -i" achieves the same effect as "sudo su -". Without the -, the shell does not load root environment, but that's it.
Anyway, there is no line containing "powered" in /etc/bluetooth/main.conf anymore - if I had to guess, it can be disabled using systemd somehow..


luisbraganca 4 years ago

Not working


FLOWXP 4 years ago

for me on Mint 17.1 Cinnamon the simple solution was to add at startup

rfkill block bluetooth

still the problem is stupid,
Mint should remember my option...is't not Windows !!


mctom 4 years ago

Or if you don't want to mess with terminal, just add a new startup application with this command:

rfkill block bluetooth


xor10 4 years ago

This article didn't work for me on Mint 17.1 Cinnamon, but solution posted on askubuntu.com worked:

sudo gedit /etc/rc.local
add the follwoing line before the exit line:
rfkill block bluetooth

If you're on a Thinkpad, you can see the original answer: http://askubuntu.com/a/2568


AshBaby 4 years ago

FlowXP, instead of restart, turn it off. When you turn in on, bluetooth will be off. Has to be.

Restart bypasses the file so will be on when a restart is executed. Will only work for turn on.


FLOWXP 4 years ago

Cinnamon 17 - not working


AshBaby 4 years ago

Hi All,

I have started using Mint again and I have Qiana, this still works for me, that too on 2 laptops.


chetvaldes 5 years ago

Didn't work for me either in Mint 16 Cinnamon.


wellspring 5 years ago

Doesn't work for me in Linux Mint 16 (xfce).

I've tried the following:

Editing /etc/rc.local to add "rfkill block bluetooth". This works if I sudo from the command line, but then obviously I'd have to do it every time I boot.

Editing /etc/bluetooth/main.conf to change InitiallyPowered to true.

Adding a kill command to my session login script (obviously in this case because I dont have root permissions and don't want to create a security hole just for a convenience script)

Most of the suggestions I've found elsewhere on the net involve disabling bluetooth entirely or leaving it on but not starting blueman. Seems to be a problem across all of Ubuntu.


kickbert1 5 years ago

it doesnt work for me (linux mint 16). I also tried false and true for RememberPowered = '' but not difference. Is there another way to do it if that doenst work?


jahid_0903014 5 years ago

nice...


NuMessiah 6 years ago

Very helpful tutorial. Would be nice if this option is available in the "Bluetooth Preferenes".


will 6 years ago

Thanks, easy to follow tutorial