They offer different flash templates with latest features.
Login

Forgot password
Register
Back
Written by:
sam33
Score: 7
votes: 9
Format: Article

 functioning Nvidia Optimus in Mint13/14/15


To fix Nvidia Optimus problems install 'Bumblebee' and 'laptop-mode-tools'.

These are working together to manage fan and cpu power-saving options.

first:

 1)      sudo add-apt-repository ppa:bumblebee/stable

This will add bumblebee to the repository. You can also add the bumblebee source to the 'synaptics...' repository section in GUI style but coding in terminal is much easier.

After initiating Code 1 , in terminal write:

2)         sudo apt-get update

3)         sudo apt-get install bumblebee bumblebee-nvidia virtualgl linux-headers-generic laptop-mode-tools

When installing items finished, you need to alter some files as following:

4)         sudo gedit /etc/bumblebee/bumblebee.conf

Go to section starting with [bumblebeed] and add 'nvidia' to => Driver=

should look like =>            Driver=nvidia

Then search for this part: [driver-nvidia] and look around in the section to find two lines like the following, if not add it:

                                         KernelDriver=nvidia-current
                                         Module=nvidia

Also read comments everytime, those are written for you to have a clue of what's going on. Sometimes the codes we need to add are just in comments '#' and are there. In that case you just need to uncomment it by removing # sign in the beginning of the code line.

Now, save and close the document, you'll come back to terminal. We need to alter on last file. So:

5)        sudo gedit /etc/init/bumblebeed.conf

Search for the following lines:

                                          start on

                                          stop on

They have some instructions in front of them. You need to alter them in order to look like the following:

                                start on    (runlevel [2345])
                                stop on     (runlevel [016])

save and close. You'll come back to terminal.

6)          sudo reboot


Tags: Nvidia+Optimus+Mint+13+14+15
Created: 5 years ago.
Last edited: 5 years ago.
Reviewed: 5 years ago.


Comments
3 years ago

MagicMint
The tutorial http://community.linuxmint.com/tutorial/view/1687 seems to me more recommendable for LM 17.  
4 years ago

philip_stefanov
Hello cant find the packages after adding the repo and update:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package bumblebee
E: Unable to locate package bumblebee-nvidia
E: Unable to locate package virtualgl
 
4 years ago

GSimpson
+1 Update for Mint 16 please.  
5 years ago

jahid_0903014
nice!  
5 years ago

CharlieSweatpants
@stem Had the same problem with "virtualgl has no installation candidate" after I upgraded to 16. Found the solution here:

https://wiki.ubuntu.com/Bumblebee#Installation

Basically, you swap out "virtualgl" for "primus", so change this - "sudo apt-get install bumblebee bumblebee-nvidia virtualgl linux-headers-generic laptop-mode-tools"

To this - "sudo apt-get install bumblebee bumblebee-nvidia primus linux-headers-generic laptop-mode-tools"

Mint 15 was based on Ubuntu 13.04, whereas Mint 16 is based on Ubuntu 13.10. I'm stil relatively new at this, so I can't give you a detailed explanation, but that worked on mine.
 
5 years ago

CharlieSweatpants
This basically solved both power and heat problems on a Dell 7720 (GeForce 650M). There are a lot of other tutorials which my noob self had trouble following or couldn't get to work. Found the above and presto: much lower temperature, and the battery no longer drains completely in 20 minutes. Many thanks.

(roger_rf, I didn't install Nvidia's driver first, I just followed the instructions here.)
 
5 years ago

larmi
sudo add-apt-repository ppa:alessandrofac93/bumblebee-config-gtk-dev
sudo apt-get update
sudo bumblebee-config or sudo apt-get install bumblebee-config-gtk
nice gui for settings and add primus parts in manual it is just lot faster!!!

unigine valley speed results are:(custom settings high, disabled, single, off, full screen 1366x768)
virtualgl 297
primus 344
and if remeber correctly win7 and same settings with opengl score is 348.
should be quite clear result.
 
5 years ago

sam33
Thanks.
one of my systems has optimus technology and I tried the tutorial on Mint 13 / 14 / and 15RC also recently. Worked on all of them.
 
5 years ago

Hammer459
Nice and crisp.
As I do not have a laptop with Nvidia Optimus I can not verify that it actually works though.
 

Other tutorials from sam33