How to make Webcam compatible with Skype.

  13 years ago

Although some webcams work on Linux Mint with Cheese and other webcam apps, they do not all work out of the box with Skype . You may have a green screen when you access your video on skype or no video at all. This issue is down to the video 4 linux libraries (V4L).  By default the current library is V4L2, to make your webcam work with Skype if you have this problem, requires the preloading of V4L to make it compatible or V4L2 conversion.

Listed below is a simple and quick way to get your webcam up and running with Skype.

I'm using gedit as my text editor, if you use a different one just substitute gedit for the editor of your choice.

Firstly open Terminal.

Copy and paste the line below into the Terminal and press Enter.

sudo gedit /usr/local/bin/skype

This will open your editor with a blank text file, copy and paste the following lines into your blank text file.

Use lines below for x86(32bit)

LD_PRELOAD=/usr/lib/libv4l/ /usr/bin/skype


Use lines below for x64(64bit)

LD_PRELOAD=/usr/lib32/libv4l/ /usr/bin/skype

Save the file and close it.

Now to make the file executable, copy and paste the following line into Terminal.

sudo chmod a+x /usr/local/bin/skype

Press Enter and close the Terminal, start Skype and webcam works.


Now your webcam is working you can optionally (to improve the quality of your webcam picture), install v4l2ucp(video for linux 2 universal control panel) from the Software Manager.

Type "v4l2ucp" in the search box and then select it.

Click "Install".

After installation go to

Menu> Preferences > Video4Linux Control Panel

This will allow you to adjust  the Contrast, Gamma, Auto Gain and Sharpness of your video. Simply click "Preview" and adjust the sliders to suit your requirements.


If your webcam has a built-in microphone, to set it to default for use with Skype, go to

Menu> Preferences > Sound

Click on the input tab and select your webcam microphone from the choices listed for input devices.

(Make sure microphone volume is not muted).


If  Skype crashes when starting video during a call, do the following.

Make a Skype call without starting your video, get the person you are calling to start their video, you should now see a light blue video icon appear at the bottom of the Skype call window.

Click on the video icon and change the video size from "Normal Size" to "Double Size"

Now start your video. (Please note that this is more of a workaround than anything else, if the person you have called stops their video before you, then Skype will crash)



As an alternative if the above fix does not work try using the lines below instead.

Use lines below for x86(32bit)

LD_PRELOAD=/usr/lib/libv4l/ /usr/bin/skype


Use lines below for x64(64bit)

LD_PRELOAD=/usr/lib32/libv4l/ /usr/bin/skype

Make file executable as above.

Tested on Linux Mint 9(Isadora) 32 and 64 bit, Linux Mint 10(Julia) 32 and 64 bit

Skype with Logitech E1000 and Genius VideoCAM GE111 webcams

tuxonapogostick 8 years ago

* Neither of these suggestions ( or ) worked for me under Mint 17.3 mate 32bit
* Note webcam is also not working with other software like "Cheese"
* in the past, this LD_PRELOAD trick would work, but apparently this is not case anymore
* what i have is a built in webcam in a sony laptop: idVendor 0x04fc Sunplus Technology Co., Ltd

Obelix 8 years ago

@Azenis: try LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/ /usr/bin/skype instead; it worked for me (also on 17.3 Cinnamon 64)

davidbow 8 years ago

Thanks - it all worked very well
I have printed out your procedure and will keep it all on hand
Thanks again
David B

Azenis 8 years ago

LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/ /usr/bin/skype

doesnt work for Linux mint 17.3 Cinnamon 64 bit.
ERROR: object '/usr/lib/x86_64-linux-gnu/libv4l/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
I dont know what is LD_PRELOAD. How to fix?

smauleon 8 years ago

Thanks for the tutorial. As others comment, it worked for me only after doing what ktaragorn recommends.
My system: Mint 17.3 64 bit
Command 'lsusb' lists my webcam as '046d:092f Logitech, Inc. QuickCam Express Plus'

klrman 8 years ago

Thanks for the info. For Mint 17.2 64 bit, I had to follow comments from ktaragorn to make it work in Skype.

djhurio 9 years ago

I am on Linux Mint 17.1 and I had to use this command for the Skype "LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/ /usr/bin/skype"

neilmurg 9 years ago

I'm working now, Mint 17, great! take note of comments from ktaragorn in comments.
Also (FIRST), check preferences in skype, video can be turned off by default....

jfleen 10 years ago

Good tutorial; I wish the title indicated the scope of the testing.

Leos 10 years ago

Thanks for This one! Made my integrated Acer Orbicam (Microdia) work with Skype. LM 15 Xfce x64

vandamme 11 years ago

Langian, I have the same problem. On my laptop, skype works great with my built-in cam & Mint 14 or 15. At work I have a video capture card hooked up to a camera, and the older Mint worked, then something happened when I upgraded both Mint and Skype (kernel upgrade to 3 in there too). /dev/video0 feed works for TVTime, Cheese, etc. and skype shows my video capture card as an input, but no "test" button like on my laptop.

The best solution: get your friends to use SIP instead. Even Google Hangout would be an improvement.

diazjavier 11 years ago

Thank you very much!!!!

In Mint 14 64bits this Work fine:

LD_PRELOAD=/usr/lib32/libv4l/ /usr/bin/skype

JML103 11 years ago


Yuri 11 years ago

Thanks! STLab WC-036 work! Excellent tutorial!

newpaul 11 years ago

The Logitech Quickcam Express camera is a software zombie, even in Windows, for which it was made (error messages show up for the default drivers & the updates in W7, even when the thing works, displaying its crappy image). Don't waste your time with it. It's a shame that Linux's reputation ends up suffering because of such crap. Down with zombieware!

Lewdsquirrel 11 years ago

Excellent tutorial, you just helped me to make the webcam work in less than 2 minutes!
Thanks again.

ktaragorn 12 years ago

This doesnt work "As-is" any more because the path to the relevant library appears to have changed. refer to

Basically, u need to change the path from
"Use lines below for x64(64bit)

LD_PRELOAD=/usr/lib32/libv4l/ /usr/bin/skype"


Use lines below for x64(64bit)

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/ /usr/bin/skype

Same path might work on 32 bit as well or just run a "locate" to find the new path. It would be great if someone, or author himself were to update this tut, it is the first place i found on a google search so should be correct

mexicanbob 12 years ago

Good Info Frank,
I have only got Lisa on my pc atm. I gave Ubuntu 11.10 unity away as it kept on freezing tries (many cures).
Anyway the only issue I have with Lisa is the webcam in skype. Cheese will show on desktop but not in skype. Two Scenarios : its me or its me

Went thru all the above but no go. An assist would be great from anyone.

Many Thanks
Bob loves Lisa

kadama 12 years ago

Thank's a lot Frankeinstein! Very good guide, the printscreens make all the difference.

I am using Ubuntu 12.04 with a Microsoft VX 1000 webcam. I couldn't get the camera to work since the 10.01 version of Ubuntu but following your guide I made it work. Rykellim's comment helped as well.

The video quality of my camera is a bit disappointing in Linux. If someone knows a good set of drivers for Microsoft cameras, please let me know.

Thanks again Frankeinstein!

kostason 12 years ago

Thank a lot!!!
Works fine on LMDE, when using JuliusP0pp tip.

newpaul 12 years ago

When I said Katya I meant Lisa. I miss K, and even Gloria, but my life moved on...

Tonya 12 years ago

Well done! Thanks a lot!

newpaul 12 years ago

Maybe this should be updated to Mint 12, visually, I mean, just for the newly arrived... Thanks again!

newpaul 12 years ago

Worked perfectly in my grampa's ubu 12.04 beta, with a Logitech Quickcam Express, which has no support for Linux or Mac. Later I offered him a Creative Webcam Live Cam Socialize L8, which is dirt cheap, has a fantastic picture and works out of the box (support for Linux clearly stated). I kept the Logitech thing and repeated this solution in my Mint Katya & everything is OK. Let's give back to these companies that treat Linux with respect (& forget the rest). Thank you so much, frankenstein, for you clear and detailed tutorial. Admirable generosity.

form-at 12 years ago

the solution if the picture of your webcam is upside-down like on my laptop is simple: add the entry -flip to the list of arguments under preview>configure preview restart skype.

Osni 12 years ago

Thanks, it's working like a charm.

For those who use Mint 12, the libv4l is now at /usr/lib/i386-linux-gnu/
If you still can't find the file, type locate in the terminal.

berlinerbeso 12 years ago

thanks, it was super! in three minutes my webcam from medion-laptop, tuned to T7300 and 4gb ddr2, is running under ubu 10.04 64bits under skype!! as soon as possible i test mint under virtual-os bts

raymund 12 years ago

Fixed the problem.
Thanks for the solution.

rykellim 12 years ago

UPDATE: The comment by JuliusP0pp worked for Skype in Linux Mint 12!

1. Edit Skype binary -
sudo gedit /usr/local/bin/skype
2. Add the following lines in the blank text -
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/ /usr/bin/skype
3. Make it executable -
sudo chmod a+x /usr/local/bin/skype
4. Start Skype

Thanks all!

rykellim 12 years ago

Neither worked for my Skype in Linux Mint 12. Has something gone wrong with this program on Linux Mint? It works OK in Ubuntu Maverick.

Simeon 12 years ago

Thank you

pleurastic 12 years ago

Worked for me on Ubuntu Lucid 10.04 64bit Logitech QuickCam for Notebooks 046d:08dd Thanks

JuliusP0pp 12 years ago

I'm using LMDE and this tutorial (and a few other ones) didn't work for me
in the ginning, but with a little tweak it does now: Instead of

LD_PRELOAD=/usr/lib/libv4l/ /usr/bin/skype

I put

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/ /usr/bin/skype

in /usr/local/bin/skype, and together with the other steps in this tutorial it works now.

JoachimL 12 years ago

I tried the ideas proposed here but failed to get my Logitech C510 to work with Skype on Linux Mint 11. Googling for a while took me to the following site and it solved my problem. I am again a happy Mint user.

kazztan0325 13 years ago

This tutorial is very easy for newbies to understand.

th1nG 13 years ago

working great! 10x

peleng 13 years ago

making a script based on
bash -c 'XLIB_SKIP_ARGB_VISUALS=1 skype'
and placing it in usr/bin solved the problem.

however, adding to mintmenu stopped skype from launching. funny enough, because standard gnome menu works with the modified command line as expected.

I've tested this tweak on Mint 10.

Firoz_usf 13 years ago

thanks I need this.

alibahaloo 13 years ago

Great tutorial. Thx :)

chevy4lady 13 years ago

Excellent tutorial! Thank you very much!

cimiuk 13 years ago

Im having problems using video cam from my laptp i have a built in cam ,is funy at times works fine then at times it says that i have no cam installed ,im using linuxmint (10) julia Gnome if that make any sens im new to this any body can help ?

jimcost 13 years ago

Great fix. Running Mint 10 on Lenovo 3000N100 with Microsoft Lifecam NX6000.
Worked like a charm!

tux_errante 13 years ago

Hi !
I'm sorry, but skype still crashing, after I've tried both methods.. any help ?

driver uvcvideo
card videowebcam
Linux mint Debian kernel 2.6.32-5amd64, Gnome

here's the output:

alessandro@alex-pc ~ $ skype
Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib/gtk-2.0/modules/ wrong ELF class: ELFCLASS64

(:27358): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/ wrong ELF class: ELFCLASS64

(:27358): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/ wrong ELF class: ELFCLASS64
/usr/local/bin/skype: line 2: 27358 Segmentation fault LD_PRELOAD=/usr/lib32/libv4l/ /usr/bin/skype

kvaju 13 years ago

Thanks man!
Great tutorial

efthialex 13 years ago

Nice! (y)

angelmiljenko 13 years ago

Great job!!!ty

grim 13 years ago

Wow, amazing tutorial, ty sir!

DonK 13 years ago

This has turned out to be an increasingly user friendly guide. The illustrations added should help us new Linux users to understand and learn how the system is organised. Just as you run through it with me showed me a lot.

rbennett 13 years ago

This is a great tutorial. It delivered and I even can use the Microsoft cam. Thanks for your detailed tutorial, that even this newbee could understand. I wish there was a tutorial on getting this same cam to work on Linux Mint in general. Keep up the great job frankeinstein!

I clicked back to this tutorial again, and it has even been made better - wow! This to me as a newbee, is the standard to what I will work to, should I ever write a tutorial. An awesome job.

frankeinstein 13 years ago

Glad I could help Donk. I have updated this tutorial to cover the Skype crash problem and also to cover the built-in microphone problems that you were experiencing.

DonK 13 years ago

Thanks for all your help frankeinstien I think this tutorial should be listed as #1 for all Skype users to get them online.

DonK 13 years ago

Thank You, now the camera works fine when I go to test now. But here's the kicker, during the call I turn on the web cam and Skype crashes.

Dell Optiplex GX260
Microsoft LifeCam NX-3000

Darrel 13 years ago

Excellent,everything just as you said, Microsoft Life-Cam NX-6000 in LM9 32bit and LMDE 32bit both 100%

banjoman 13 years ago

this is what community computing is all about, thanks for the knowledge and effort put into this tutorial - most problems can be overcome with perseverance and support...

CharlesF 13 years ago

This was the only thing that didn't work for me in Mint.....

This is one MINT solution. Thank you for sharing it!

minhajz 13 years ago

Awesome .... Thanks a lot brother ... now my cam works fine...

Elisa 13 years ago


tihomir 13 years ago

Thank you very much!After installing Isadora(I used Gloria before),my webcam Genius stopped working with Skype but it worked with Cheese app.Since I am not computer wizard,I would never find solution,thank you again!And now I even have much better video quality than with Gloria.